When applying replicated changes for a row that is missing one or more columns, pglogical…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-250.
Summary
When applying replicated changes for a row that is missing one or more columns, pglogical evaluates the affected table's default expressions on the subscriber. Because the apply worker runs at a privilege level equivalent to a PostgreSQL superuser in default installations, any function invoked by such a default expression also runs at that privilege. A party acting as the publisher can use this path to cause functions to be executed on the subscriber as superuser, escalating from a role permitted to use pglogical to full superuser. This is a second, independent path to the same superuser escalation tracked under CVE-2026-50736 (the pglogical queue issue). To exploit the issue an attacker must be able to direct a subscription at an endpoint they control. In default installations this requires privileges normally reserved for a superuser, so the issue is most relevant to managed deployments where the ability to create subscriptions has been delegated to non-superuser roles.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| EnterpriseDB | pglogical | 2 to before 2.4.8 | 2.4.8 | Patch available | CNA |
- pglogical VendorEnterpriseDB Affected 2 to before 2.4.8 Fixed in 2.4.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:enterprisedb:pglogical:*:*:*:*:*:postgresql:*:* | 2.0.0 to before 2.4.8 | Vulnerable | EnterpriseDB |
- cpe:2.3:a:enterprisedb:pglogical:*:*:*:*:*:postgresql:*:* Versions 2.0.0 to before 2.4.8 Vulnerable ·EnterpriseDB
Remediation
- Fix · CNA pglogical (EnterpriseDB) Fixed in 2.4.8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
EnterpriseDB pglogical 2.4.8
4 records Highest priority Priority MEDIUM 2 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2026-37399 SQL injection in EnterpriseDB pglogicalPriority MEDIUM 41
- TI-2026-37401 Use after free in EnterpriseDB pglogicalPriority LOW 36
- TI-2026-37398 Out-of-bounds read in EnterpriseDB pglogicalPriority LOW 27
Timeline
- 2026-10-02 Threatist record created from CVE-2026-50737
- 2026-10-03 Alias added: GHSA-h7hw-g87c-29wh
References
More EnterpriseDB Pglogical vulnerabilities
- TI-2026-37399 SQL injection in EnterpriseDB pglogical CVSS 4.0CRITICAL 9.0
- TI-2026-37401 Use after free in EnterpriseDB pglogical CVSS 4.0HIGH 7.7
- TI-2026-37398 Out-of-bounds read in EnterpriseDB pglogical CVSS 4.0MEDIUM 6.1
Sources
- CVE-2026-50737 · CVE Program
- CVE-2026-50737 · NVD
- FIRST EPSS
- GHSA-h7hw-g87c-29wh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences