langflow-ai langflow v1.9.3 is affected by: Code Injection.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
langflow-ai langflow v1.9.3 is affected by: Code Injection. The impact is: execute arbitrary code (remote). The component is: src/backend/base/langflow/api/v1/validate.py:validate-post_validate_code-a-real-authenticated-http-post-to-api-v1. The attack vector is: Attack surface: HTTP or browser-backed service path. A public-facing route accepts raw Python source and forwards it into a server-side compile/exec validation path without any visible entitlement guard. ¶¶ A weakness has been identified in langflow-ai langflow up to 1.9.3. langflow contains a code injection vulnerability in validate-post_validate_code-a-real-authenticated-http-post-to-api-v1 (src/backend/base/langflow/api/v1/validate.py:13). An authenticated attacker can execute arbitrary Python code on the server by submitting malicious code to the /api/v1/validate/code endpoint, which directly executes user-supplied code without sandboxing or security controls.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | langflow (PyPI) | 1.7.2 to before 1.10.1 | 1.10.1 | Patch available | GHSA-w584-2h2r-2hvf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- langflow (PyPI) Vendor— Affected 1.7.2 to before 1.10.1 Fixed in 1.10.1 Patch available GHSA-w584-2h2r-2hvf
Remediation
- Fix · GHSA-w584-2h2r-2hvf langflow (PyPI) Fixed in 1.10.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-51886
- 2026-10-03 Alias added: GHSA-qqw9-2vj9-hx7r
- 2026-10-06 CVSS score added · CISA ADP
- 2026-10-06 Weakness changed · CISA ADP
- 2026-10-06 CISA SSVC decision points changed
- 2026-10-06 Priority changed: LOW → HIGH
- 2026-10-06 Alias added: GHSA-w584-2h2r-2hvf
- 2026-10-06 Fix available: PyPI/[email protected] · GHSA-w584-2h2r-2hvf
- 2026-10-06 CVSS score added · GHSA-w584-2h2r-2hvf
- 2026-10-06 Weakness changed · GHSA-w584-2h2r-2hvf
- 2026-10-06 8 new references · GHSA-w584-2h2r-2hvf
References
Other 7
- https://github.com/langflow-ai/langflow/issues/13336
- https://gist.github.com/Ro1ME/c11b1e63e4e8fca6b25275144f25ec2a
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-w584-2h2r-2hvf
- https://github.com/langflow-ai/langflow/pull/13696
- https://github.com/langflow-ai/langflow/commit/e7c33dbaade20b5295c7fa26bf83cc1ff68fba02
- https://github.com/langflow-ai/langflow
- https://github.com/langflow-ai/langflow/releases/tag/v1.10.1
Sources
- CVE-2026-51886 · CVE Program
- CVE-2026-51886 · NVD
- FIRST EPSS
- GHSA-qqw9-2vj9-hx7r · GitHub Advisory Database · CC BY 4.0
- GHSA-w584-2h2r-2hvf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences