Linuxfabrik Monitoring Plugins Sudoers: /usr/bin/apt-get arguments allow privilege escalation
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-88.
Summary
Linuxfabrik Monitoring Plugins provides monitoring plugins for Icinga, Nagios, and related systems. Prior to version 5.1.0, the shipped assets/sudoers/Debian.sudoers policy allowed the nagios or icinga account to execute /usr/bin/apt-get as root without restricting its arguments. An attacker who already controls that monitoring account can supply the APT::Update::Pre-Invoke option to execute an arbitrary command while apt-get runs with root privileges, resulting in a root shell and complete compromise of the host. The vulnerable rule supports the check-plugins/deb-updates/deb-updates plugin, but it authorized arbitrary apt-get argument sequences rather than only the required apt-get update --quiet 2 command. This issue is fixed in version 5.1.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linuxfabrik | monitoring-plugins | before 5.1.0 | 5.1.0 | Patch available | CNA |
| — | linuxfabrik-lib (PyPI) | before 5.1.0 | 5.1.0 | Patch available | GHSA-8w6w-23mq-h8rg |
- monitoring-plugins VendorLinuxfabrik Affected before 5.1.0 Fixed in 5.1.0 Patch available CNA
- linuxfabrik-lib (PyPI) Vendor— Affected before 5.1.0 Fixed in 5.1.0 Patch available GHSA-8w6w-23mq-h8rg
Remediation
- Fix · CNA monitoring-plugins (Linuxfabrik) Fixed in 5.1.0
- Fix · GHSA-8w6w-23mq-h8rg linuxfabrik-lib (PyPI) Fixed in 5.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-52817
- 2026-10-03 Alias added: GHSA-8w6w-23mq-h8rg
References
Other 5
- https://github.com/Linuxfabrik/monitoring-plugins/security/advisories/GHSA-8w6w-23mq-h8rg
- https://github.com/Linuxfabrik/monitoring-plugins/commit/694b5daeebadc9a51428f3de1acff7b1f737642f
- https://github.com/Linuxfabrik/monitoring-plugins/blob/main/CHANGELOG.md#v510---2026-05-30
- https://github.com/Linuxfabrik/monitoring-plugins/releases/tag/v5.1.0
- https://github.com/Linuxfabrik/monitoring-plugins
More Linuxfabrik vulnerabilities
- TI-2026-39994 linuxfabrik-lib: Local privilege escalation using embedded command CVSS 3.1HIGH 7.8
- TI-2026-51979 linuxfabrik-lib: Arbitrary root file read via live --test argument (lib.lftest) across sudoers-whitelisted plugins (LPE) CVSS 3.1MEDIUM 5.5
- TI-2026-51978 Linuxfabrik Monitoring Plugins: Arbitrary root file disclosure via unconfined --filename in logfile plugin (sudoers LPE) CVSS 3.1MEDIUM 5.5
- TI-2026-38766 linuxfabrik-lib: Insecure creation of SQLite databases CVSS 4.0LOW 2.0
- TI-2026-47716 Linuxfabrik monitoring-plugins: SSRF and auth-token disclosure via unvalidated @odata.id link in redfish-* plugins CVSS 4.0HIGH 8.3
- TI-2026-47715 linuxfabrik-lib: fetch() forwards credential headers across a cross-origin redirect CVSS 4.0MEDIUM 6.0
Sources
- CVE-2026-52817 · CVE Program
- CVE-2026-52817 · NVD
- FIRST EPSS
- GHSA-8w6w-23mq-h8rg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences