netfilter: ip6t_hbh: reject oversized option lists
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: netfilter: ip6t_hbh: reject oversized option lists struct ip6t_opts stores at most IP6T_OPTS_OPTSNR option descriptors, but hbh_mt6_check() does not reject larger optsnr values supplied from userspace. Validate optsnr in the rule setup path so only match data that fits the fixed-size opts array can be installed. This follows the existing xtables pattern of rejecting invalid user-provided counts in checkentry() and keeps the packet matching path unchanged. `struct ip6t_opts` has a fixed `opts[IP6T_OPTS_OPTSNR]` array, where `IP6T_OPTS_OPTSNR` is 16, then off-by-one array access is possible: [ 137.924693][ T8692] UBSAN: array-index-out-of-bounds in ../net/ipv6/netfilter/ip6t_hbh.c:110:29 [ 137.926167][ T8692] index 16 is out of range for type '__u16 [16]'
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.12 and later | 5.10.258, 5.15.209, 6.1.175, 6.6.142, 6.12.92, 6.18.34, 7.0.11, 7.1 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.12 and later Fixed in 5.10.258, 5.15.209, 6.1.175, 6.6.142, 6.12.92, 6.18.34, 7.0.11, 7.1 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.12.1 to before 5.10.258; 5.11 to before 5.15.209; 5.16 to before 6.1.175; 6.2 to before 6.6.142; 6.7 to before 6.12.92; 6.13 to before 6.18.34; 6.19 to before 7.0.11 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.12:-:*:*:*:*:*:* | 2.6.12 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.12:rc2:*:*:*:*:*:* | 2.6.12 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.12:rc3:*:*:*:*:*:* | 2.6.12 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.12:rc4:*:*:*:*:*:* | 2.6.12 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.12:rc5:*:*:*:*:*:* | 2.6.12 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:* | 7.1 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc2:*:*:*:*:*:* | 7.1 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc3:*:*:*:*:*:* | 7.1 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc4:*:*:*:*:*:* | 7.1 rc4 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.12.1 to before 5.10.258; 5.11 to before 5.15.209; 5.16 to before 6.1.175; 6.2 to before 6.6.142; 6.7 to before 6.12.92; 6.13 to before 6.18.34; 6.19 to before 7.0.11 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.12:-:*:*:*:*:*:* Versions 2.6.12 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.12:rc2:*:*:*:*:*:* Versions 2.6.12 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.12:rc3:*:*:*:*:*:* Versions 2.6.12 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.12:rc4:*:*:*:*:*:* Versions 2.6.12 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.12:rc5:*:*:*:*:*:* Versions 2.6.12 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:* Versions 7.1 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc2:*:*:*:*:*:* Versions 7.1 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc3:*:*:*:*:*:* Versions 7.1 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc4:*:*:*:*:*:* Versions 7.1 rc4 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.258, 5.15.209, 6.1.175, 6.6.142, 6.12.92, 6.18.34, 7.0.11, 7.1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-52915
- 2026-10-03 Alias added: GHSA-9hfh-p7qh-475c
- 2026-10-16 CISA SSVC decision points changed
- 2026-10-19 Weakness changed · CISA ADP
References
Patch 8
- https://git.kernel.org/stable/c/2d523ba48d4ecc46acfb6aba548292cfcce1ac02
- https://git.kernel.org/stable/c/588933f1a2ca5ff99274f8c9f25dc3a25d0191c3
- https://git.kernel.org/stable/c/784aadea7a108c9f90985683caa87fb0198c6a39
- https://git.kernel.org/stable/c/41ec2e242f1702e8370ddfe14d22b7a766021c3e
- https://git.kernel.org/stable/c/db0250470f023f159094052c0bd5ab026a88ae93
- https://git.kernel.org/stable/c/57b0ac5e1b46f1f0338dff392ef2092e2871b412
- https://git.kernel.org/stable/c/6feb43c0995ab3a9c826707eb46541a1696fe4f7
- https://git.kernel.org/stable/c/4322dcde6b4173c2d8e8e6118ed290794263bcc8
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-52915 · CVE Program
- CVE-2026-52915 · NVD
- FIRST EPSS
- GHSA-9hfh-p7qh-475c · GitHub Advisory Database · CC BY 4.0
- CVE-2026-52915 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences