accel/ethosu: reject DMA commands with uninitialized length
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: accel/ethosu: reject DMA commands with uninitialized length cmd_state_init() initializes the command state with memset(0xff), leaving dma->len at U64_MAX to signal missing setup. The only setter is NPU_SET_DMA0_LEN; if userspace omits this command and issues NPU_OP_DMA_START, dma->len remains U64_MAX. In dma_length(), a positive stride added to U64_MAX wraps to a small value. With size0 == 1, check_mul_overflow() does not trigger and dma_length() returns 0 instead of U64_MAX. The caller's U64_MAX check then passes, region_size[] stays 0, and the bounds check in ethosu_job.c is bypassed, allowing hardware to execute DMA with stale physical addresses. Fix by checking for U64_MAX at the start of dma_length() before any arithmetic, consistent with the sentinel value used throughout the driver to detect uninitialized fields.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.19 and later | 7.0.13, 7.1 | Patch available | CNA |
- Linux VendorLinux Affected 6.19 and later Fixed in 7.0.13, 7.1 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.19 to before 7.0.13 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:* | 7.1 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc2:*:*:*:*:*:* | 7.1 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc3:*:*:*:*:*:* | 7.1 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc4:*:*:*:*:*:* | 7.1 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc5:*:*:*:*:*:* | 7.1 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc6:*:*:*:*:*:* | 7.1 rc6 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.19 to before 7.0.13 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:* Versions 7.1 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc2:*:*:*:*:*:* Versions 7.1 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc3:*:*:*:*:*:* Versions 7.1 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc4:*:*:*:*:*:* Versions 7.1 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc5:*:*:*:*:*:* Versions 7.1 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc6:*:*:*:*:*:* Versions 7.1 rc6 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 7.0.13, 7.1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-53170
- 2026-10-03 Alias added: GHSA-8pg6-rv6x-wjc2
- 2026-10-20 Affected versions changed · Red Hat
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-53170 · CVE Program
- CVE-2026-53170 · NVD
- FIRST EPSS
- GHSA-8pg6-rv6x-wjc2 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-53170 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences