staging: rtl8723bs: fix buffer over-read in rtw_update_protection
Priority LOW 30CWE-125Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: staging: rtl8723bs: fix buffer over-read in rtw_update_protection rtw_update_protection() is called with a pointer offset into the ies buffer but the full ie_length is passed, causing a potential buffer over-read.
Why it matters now
EPSS 0.00166 5th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 6.6.160, 6.12.95, 6.18.36 +2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.15 and later | 6.6.160, 6.12.95, 6.18.36, 7.0.13, 7.1 | Patch available | CNA |
- Linux VendorLinux Affected 5.15 and later Fixed in 6.6.160, 6.12.95, 6.18.36, 7.0.13, 7.1 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.15 to before 6.18.36; 6.19 to before 7.0.13 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:* | 7.1 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc2:*:*:*:*:*:* | 7.1 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc3:*:*:*:*:*:* | 7.1 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc4:*:*:*:*:*:* | 7.1 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc5:*:*:*:*:*:* | 7.1 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc6:*:*:*:*:*:* | 7.1 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc7:*:*:*:*:*:* | 7.1 rc7 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.15 to before 6.18.36; 6.19 to before 7.0.13 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:* Versions 7.1 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc2:*:*:*:*:*:* Versions 7.1 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc3:*:*:*:*:*:* Versions 7.1 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc4:*:*:*:*:*:* Versions 7.1 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc5:*:*:*:*:*:* Versions 7.1 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc6:*:*:*:*:*:* Versions 7.1 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc7:*:*:*:*:*:* Versions 7.1 rc7 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.6.160, 6.12.95, 6.18.36, 7.0.13, 7.1
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-53179
- 2026-10-03 Alias added: GHSA-jr2w-mc6v-cfpj
- 2026-10-21 Fix available: Linux/[email protected], Linux/Linux@d95edbbf7830d77ad68d437c384055eac8cd9892 · CNA
- 2026-10-21 1 new reference · CNA
References
Patch 4
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-53179 · CVE Program
- CVE-2026-53179 · NVD
- FIRST EPSS
- GHSA-jr2w-mc6v-cfpj · GitHub Advisory Database · CC BY 4.0
- CVE-2026-53179 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences