Read the docs
TI-2026-38335 Aliases CVE-2026-53249GHSA-r3wj-w7v3-6mqq

ipv4: restrict IPOPT_SSRR and IPOPT_LSRR options

Priority LOW 24Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 5 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.

Summary

In the Linux kernel, the following vulnerability has been resolved: ipv4: restrict IPOPT_SSRR and IPOPT_LSRR options This patch restricts setting Loose Source and Record Route (LSRR) and Strict Source and Record Route (SSRR) IP options to users with CAP_NET_RAW capability. This prevents unprivileged applications from forcing packets to route through attacker-controlled nodes to leak TCP ISN and possibly other protocol information. While LSRR and SSRR are commonly filtered in many network environments, they may still be supported and forwarded along some network paths. RFC 7126 (Recommendations on Filtering of IPv4 Packets Containing IPv4 Options) recommend to drop these options in 4.3 and 4.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00129 2nd percentileScored 2026-11-07
Fix Partial Linux (Linux): 5.10.259, 5.15.210, 6.1.176 +5Red Hat: 5 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux2.6.12 and later5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 6.18.36, 7.0.13, 7.1Patch availableCNA
  • Linux VendorLinux Affected 2.6.12 and later Fixed in 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 6.18.36, 7.0.13, 7.1 Patch available CNA

CPE configurations NVD · 12

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*2.6.12.1 to before 5.10.259; 5.11 to before 5.15.210; 5.16 to before 6.1.176; 6.2 to before 6.6.143; 6.7 to before 6.12.94; 6.13 to before 6.18.36; 6.19 to before 7.0.13VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.12:-:*:*:*:*:*:*2.6.12VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.12:rc2:*:*:*:*:*:*2.6.12 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.12:rc3:*:*:*:*:*:*2.6.12 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.12:rc4:*:*:*:*:*:*2.6.12 rc4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:2.6.12:rc5:*:*:*:*:*:*2.6.12 rc5VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:*7.1 rc1VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.1:rc2:*:*:*:*:*:*7.1 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.1:rc3:*:*:*:*:*:*7.1 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.1:rc4:*:*:*:*:*:*7.1 rc4VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.12.1 to before 5.10.259; 5.11 to before 5.15.210; 5.16 to before 6.1.176; 6.2 to before 6.6.143; 6.7 to before 6.12.94; 6.13 to before 6.18.36; 6.19 to before 7.0.13 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.12:-:*:*:*:*:*:* Versions 2.6.12 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.12:rc2:*:*:*:*:*:* Versions 2.6.12 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.12:rc3:*:*:*:*:*:* Versions 2.6.12 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.12:rc4:*:*:*:*:*:* Versions 2.6.12 rc4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:2.6.12:rc5:*:*:*:*:*:* Versions 2.6.12 rc5 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:* Versions 7.1 rc1 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.1:rc2:*:*:*:*:*:* Versions 7.1 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.1:rc3:*:*:*:*:*:* Versions 7.1 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.1:rc4:*:*:*:*:*:* Versions 7.1 rc4 Vulnerable ·Linux
Show 2 more CPE
CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:7.1:rc5:*:*:*:*:*:*7.1 rc5VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.1:rc6:*:*:*:*:*:*7.1 rc6VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:7.1:rc5:*:*:*:*:*:* Versions 7.1 rc5 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.1:rc6:*:*:*:*:*:* Versions 7.1 rc6 Vulnerable ·Linux

Remediation

  • Fix · CNA Linux (Linux) Fixed in 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 6.18.36, 7.0.13, 7.1

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 10AffectedNo fix yet
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix yet
Red Hat Enterprise Linux 8AffectedNo fix yet
Red Hat Enterprise Linux 9AffectedNo fix yet

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-53249
  2. 2026-10-03 Alias added: GHSA-r3wj-w7v3-6mqq
  3. 2026-11-06 CISA SSVC decision points changed

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources