tee: optee: prevent use-after-free when the client exits before the supplicant
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-416 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: tee: optee: prevent use-after-free when the client exits before the supplicant Commit 70b0d6b0a199 ("tee: optee: Fix supplicant wait loop") made the client wait as killable so it can be interrupted during shutdown or after a supplicant crash. This changes the original lifetime expectations: the client task can now terminate while the supplicant is still processing its request. If the client exits first it removes the request from its queue and kfree()s it, while the request ID remains in supp->idr. A subsequent lookup on the supplicant path then dereferences freed memory, leading to a use-after-free. Serialise access to the request with supp->mutex: * Hold supp->mutex in optee_supp_recv() and optee_supp_send() while looking up and touching the request. * Let optee_supp_thrd_req() notice that the client has terminated and signal optee_supp_send() accordingly. With these changes the request cannot be freed while the supplicant still has a reference, eliminating the race.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.10.235 to before 5.10.259; 5.15.179 to before 5.15.210; 6.1.130 to before 6.1.176; 6.6.80 to before 6.6.143; 6.12.17 to before 6.12.94; 5.4.291 to before 5.5; 6.13.5 to before 6.14 | 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 5.5, 6.14 | Patch available | CNA |
| Linux | Linux | 6.14 and later | 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 6.18.36, 7.0.13, 7.1 | Patch available | CNA |
- Linux VendorLinux Affected 5.10.235 to before 5.10.259; 5.15.179 to before 5.15.210; 6.1.130 to before 6.1.176; 6.6.80 to before 6.6.143; 6.12.17 to before 6.12.94; 5.4.291 to before 5.5; 6.13.5 to before 6.14 Fixed in 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 5.5, 6.14 Patch available CNA
- Linux VendorLinux Affected 6.14 and later Fixed in 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 6.18.36, 7.0.13, 7.1 Patch available CNA
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.4.291 to before 5.5; 5.10.235 to before 5.10.259; 5.15.179 to before 5.15.210; 6.1.130 to before 6.1.176; 6.6.80 to before 6.6.143; 6.12.17 to before 6.12.94; 6.13.5 to before 6.14; 6.14.1 to before 6.18.36; 6.19 to before 7.0.13 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:-:*:*:*:*:*:* | 6.14 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc4:*:*:*:*:*:* | 6.14 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc5:*:*:*:*:*:* | 6.14 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc6:*:*:*:*:*:* | 6.14 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc7:*:*:*:*:*:* | 6.14 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:* | 7.1 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc2:*:*:*:*:*:* | 7.1 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc3:*:*:*:*:*:* | 7.1 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.1:rc4:*:*:*:*:*:* | 7.1 rc4 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.4.291 to before 5.5; 5.10.235 to before 5.10.259; 5.15.179 to before 5.15.210; 6.1.130 to before 6.1.176; 6.6.80 to before 6.6.143; 6.12.17 to before 6.12.94; 6.13.5 to before 6.14; 6.14.1 to before 6.18.36; 6.19 to before 7.0.13 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:-:*:*:*:*:*:* Versions 6.14 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc4:*:*:*:*:*:* Versions 6.14 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc5:*:*:*:*:*:* Versions 6.14 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc6:*:*:*:*:*:* Versions 6.14 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc7:*:*:*:*:*:* Versions 6.14 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:* Versions 7.1 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc2:*:*:*:*:*:* Versions 7.1 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc3:*:*:*:*:*:* Versions 7.1 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.1:rc4:*:*:*:*:*:* Versions 7.1 rc4 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 5.5, 6.14
- Fix · CNA Linux (Linux) Fixed in 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 6.18.36, 7.0.13, 7.1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-53273
- 2026-10-03 Alias added: GHSA-q972-3fgv-wchc
- 2026-10-16 CISA SSVC decision points changed
- 2026-10-19 Weakness changed · CISA ADP
- 2026-10-20 Affected versions changed · Red Hat
References
Patch 8
- https://git.kernel.org/stable/c/416259cb5bffecaaae5f76539deb535a8c1b2c34
- https://git.kernel.org/stable/c/724d0caffd4204b46f78efe22f18f8338031c6e1
- https://git.kernel.org/stable/c/ae847ab29ded2d7cece4d5970f0edefa4137bf2f
- https://git.kernel.org/stable/c/9a0dc9279d0907b198f205a693aedf696b08145d
- https://git.kernel.org/stable/c/d366a01475f927402c96a3fe78bfc06b924fc87d
- https://git.kernel.org/stable/c/d5b57bb314d79e99bebb58a53588fa11dd4dbf69
- https://git.kernel.org/stable/c/373152c94e57e9592b68c100e224fbd943cfd608
- https://git.kernel.org/stable/c/387a926ee166814611acecb960207fe2f3c4fd3e
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-53273 · CVE Program
- CVE-2026-53273 · NVD
- FIRST EPSS
- GHSA-q972-3fgv-wchc · GitHub Advisory Database · CC BY 4.0
- CVE-2026-53273 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences