OpenClaw < 2026.5.26 - Insufficient Environment Variable Sanitization in Node.js Control Variables
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
OpenClaw before 2026.5.26 contains an insufficient sanitization vulnerability in the host environment sanitizer that allows Node.js control variables to bypass validation. Attackers with access to workspace .env files, tool environment overrides, or skill environment blocks can pass malicious Node.js control variables to influence child processes or coverage output paths.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenClaw | OpenClaw | before 2026.5.26 | 2026.5.26 | Patch available | CNA |
| — | openclaw (npm) | before 2026.5.26 | 2026.5.26 | Patch available | GHSA-ccwh-wwpp-6wg5 |
- OpenClaw VendorOpenClaw Affected before 2026.5.26 Fixed in 2026.5.26 Patch available CNA
- openclaw (npm) Vendor— Affected before 2026.5.26 Fixed in 2026.5.26 Patch available GHSA-ccwh-wwpp-6wg5
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:node.js:*:* | before 2026.5.26 | Vulnerable | OpenClaw |
| cpe:2.3:a:openclaw:openclaw:2026.5.26:beta1:*:*:*:node.js:*:* | 2026.5.26 beta1 | Vulnerable | OpenClaw |
| cpe:2.3:a:openclaw:openclaw:2026.5.26:beta2:*:*:*:node.js:*:* | 2026.5.26 beta2 | Vulnerable | OpenClaw |
- cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:node.js:*:* Versions before 2026.5.26 Vulnerable ·OpenClaw
- cpe:2.3:a:openclaw:openclaw:2026.5.26:beta1:*:*:*:node.js:*:* Versions 2026.5.26 beta1 Vulnerable ·OpenClaw
- cpe:2.3:a:openclaw:openclaw:2026.5.26:beta2:*:*:*:node.js:*:* Versions 2026.5.26 beta2 Vulnerable ·OpenClaw
Remediation
- Fix · CNA OpenClaw (OpenClaw) Fixed in 2026.5.26
- Fix · GHSA-ccwh-wwpp-6wg5 openclaw (npm) Fixed in 2026.5.26 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
OpenClaw 2026.5.26
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2026-38839 OpenClaw < 2026.5.26 - Node Token Revocation Bypass via Pairing-Scoped Device SessionPriority LOW 39
- TI-2026-38855 OpenClaw < 2026.5.26 - Hostname Validation Bypass via Trailing-Dot InconsistencyPriority LOW 26
- TI-2026-38844 OpenClaw < 2026.5.26 - Exec Allowlist Bypass via Transparent Command WrappersPriority LOW 11
Timeline
- 2026-10-02 Threatist record created from CVE-2026-53864
- 2026-10-03 Alias added: GHSA-ccwh-wwpp-6wg5
References
More Openclaw vulnerabilities
- TI-2026-25309 OpenClaw < 2026.3.28 Media Parsing Path Traversal to Arbitrary File Read CVSS 4.0HIGH 8.7
- TI-2026-20394 Exposure of resource to wrong sphere in OpenClaw CVSS 3.1HIGH 8.8
- TI-2026-27742 OpenClaw < 2026.3.24 - Arbitrary Code Execution via .npmrc in Local Plugin/Hook Installation CVSS 4.0HIGH 8.4
- TI-2026-27766 OpenClaw < 2026.3.24 - Denial of Service via Feishu Webhook Pre-Auth Body Parsing CVSS 4.0MEDIUM 6.9
- TI-2026-07315 OpenClaw bluebubbles Webhook monitor.ts handleBlueBubblesWebhookRequest improper authentication CVSS 4.0MEDIUM 6.9
- TI-2026-17789 OpenClaw < 2026.2.22 - Allowlist Bypass via Command Substitution in system.run CVSS 4.0HIGH 7.5
Sources
- CVE-2026-53864 · CVE Program
- CVE-2026-53864 · NVD
- FIRST EPSS
- GHSA-ccwh-wwpp-6wg5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences