Heap buffer over-read in GDALRaster
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · Low
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
An issue was discovered in Django 6.0 before 6.0.7 and 5.2 before 5.2.16. `django.contrib.gis.gdal.GDALRaster` over-reads its in-memory buffer when constructed from a bytes object, which can disclose adjacent memory or cause service degradation via a potential segmentation fault when the `vsi_buffer` property is accessed. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Bence Nagy for reporting this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| djangoproject | Django | 6.0 to before 6.0.7; 5.2 to before 5.2.16 | 6.0.7, 5.2.16 | Patch available | CNA |
| — | django (PyPI) | before 5.2.16 | 5.2.16 | Patch available | GHSA-crhf-3pfg-w68w |
| — | django (PyPI) | 6.0.0 to before 6.0.7 | 6.0.7 | Patch available | GHSA-crhf-3pfg-w68w |
- Django Vendordjangoproject Affected 6.0 to before 6.0.7; 5.2 to before 5.2.16 Fixed in 6.0.7, 5.2.16 Patch available CNA
- django (PyPI) Vendor— Affected before 5.2.16 Fixed in 5.2.16 Patch available GHSA-crhf-3pfg-w68w
- django (PyPI) Vendor— Affected 6.0.0 to before 6.0.7 Fixed in 6.0.7 Patch available GHSA-crhf-3pfg-w68w
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 5.2 to before 5.2.16; 6.0 to before 6.0.7 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 5.2 to before 5.2.16; 6.0 to before 6.0.7 Vulnerable ·djangoproject
Remediation
- Fix · CNA Django (djangoproject) Fixed in 6.0.7, 5.2.16
- Fix · GHSA-crhf-3pfg-w68w django (PyPI) Fixed in 5.2.16 Advisory →
- Fix · GHSA-crhf-3pfg-w68w django (PyPI) Fixed in 6.0.7 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
djangoproject Django — Django security releases issued: 6.0.7 and 5.2.16
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2026-38874 Header injection possibility since DomainNameValidator accepted newlines in inputPriority LOW 24
- TI-2026-35944 Potential exposure of private data via cached Set-Cookie responsePriority LOW 12
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Discovery 2 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
| Self-service automation portal 2 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-53877
- 2026-10-03 Alias added: GHSA-crhf-3pfg-w68w
References
Other 7
- Django releases announcements
- https://github.com/django/django/commit/38dfbd27d7d4f4e6eaa087d7a90f2613fbf55b3a
- https://github.com/django/django/commit/6c66eb8cec52b303af85c2c6e4dd00aa37654dbc
- https://github.com/django/django/commit/6ca2bbe2efce21010eff48f1f36a3f621d698ed8
- https://docs.djangoproject.com/en/dev/releases/security
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2026-2091.yaml
- https://www.djangoproject.com/weblog/2026/jul/07/security-releases
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-53877 · CVE Program
- CVE-2026-53877 · NVD
- FIRST EPSS
- GHSA-crhf-3pfg-w68w · GitHub Advisory Database · CC BY 4.0
- CVE-2026-53877 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences