Pi: Predictable temporary extension install paths allow local privilege escalation on shared Linux hosts
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Pi is a minimal terminal coding harness. From 0.74.0 until 0.78.1, Pi versions with temporary npm or git extension package installs used predictable paths under the operating system temporary directory. On Linux-based multi-user systems, a local attacker who can write to the shared temporary directory could prepare the expected package location before another user runs pi with a temporary extension package source. Pi could then load attacker-controlled extension code in the victim user's process. This vulnerability is fixed in 0.78.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| earendil-works | pi | 0.74.0 to before 0.78.1 | 0.78.1 | Patch available | CNA |
| — | @earendil-works/pi-coding-agent (npm) | 0.74.0 to before 0.78.1 | 0.78.1 | Patch available | GHSA-jfgx-wxx8-mp94 |
| — | @mariozechner/pi-coding-agent (npm) | 0.50.0 – 0.73.1 | — | No fix listed | GHSA-jfgx-wxx8-mp94 |
- pi Vendorearendil-works Affected 0.74.0 to before 0.78.1 Fixed in 0.78.1 Patch available CNA
- @earendil-works/pi-coding-agent (npm) Vendor— Affected 0.74.0 to before 0.78.1 Fixed in 0.78.1 Patch available GHSA-jfgx-wxx8-mp94
- @mariozechner/pi-coding-agent (npm) Vendor— Affected 0.50.0 – 0.73.1 Fixed in — No fix listed GHSA-jfgx-wxx8-mp94
Remediation
- Fix · CNA pi (earendil-works) Fixed in 0.78.1
- Fix · GHSA-jfgx-wxx8-mp94 @earendil-works/pi-coding-agent (npm) Fixed in 0.78.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-54328
- 2026-10-03 Alias added: GHSA-jfgx-wxx8-mp94
References
Other 6
- https://github.com/earendil-works/pi/security/advisories/GHSA-jfgx-wxx8-mp94
- https://github.com/earendil-works/pi/pull/5345
- https://github.com/earendil-works/pi/commit/a98e087e5d08ea2a536bf73dbb0aebb87c3ef72e
- https://github.com/earendil-works/pi/commit/ea3465a8e371a12d0167a06b60f93878e3a3df44
- https://github.com/earendil-works/pi/releases/tag/v0.78.1
- https://github.com/earendil-works/pi
More earendil-works vulnerabilities
- TI-2026-39220 Pi loads project-local extensions without approval CVSS 3.1MEDIUM 4.4
- TI-2026-39221 Pi: Potential XSS in HTML session exports via Markdown URL sanitization bypass CVSS 3.1LOW 2.5
- TI-2026-39222 Pi: Race condition in auth.json writes could expose stored credentials CVSS 3.1LOW 2.2
Sources
- CVE-2026-54328 · CVE Program
- CVE-2026-54328 · NVD
- FIRST EPSS
- GHSA-jfgx-wxx8-mp94 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences