@arikusi/deepseek-mcp-server Missing Authentication on Self-Hosted HTTP MCP Endpoint
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-306.
Summary
DeepSeek MCP Server is an MCP server for DeepSeek V4. Starting in version 1.4.2 and prior to version 1.8.0, the self-hosted HTTP transport of `@arikusi/deepseek-mcp-server` exposes `POST /mcp` without any authentication: `createMcpExpressApp` is called without an `authProvider` and no middleware guards the route, so any network-reachable client can issue an unauthenticated `initialize` request and obtain a valid MCP session identifier. In reproduced testing against commit `5e1302171e99`, an unauthenticated client was able to initialize a session, enumerate tools, and invoke the local `deepseek_sessions` tool with no credentials. The same unauthenticated session also exposes `deepseek_chat`, whose handler uses the server-side `DEEPSEEK_API_KEY` when self-hosted deployments configure one. This issue applies to self-hosted HTTP mode, not the separately documented hosted BYOK endpoint in `README.md`, which expects an `Authorization: Bearer ...` header. Upstream self-hosted container assets enable HTTP mode by default (`Dockerfile`) and publish port `3000` (`docker-compose.yml`). Version 1.8.0 contains a patch for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| arikusi | deepseek-mcp-server | 1.4.2 to before 1.8.0 | 1.8.0 | Patch available | CNA |
| — | @arikusi/deepseek-mcp-server (npm) | 1.4.2 to before 1.8.0 | 1.8.0 | Patch available | GHSA-72f3-6w86-7rv3 |
- deepseek-mcp-server Vendorarikusi Affected 1.4.2 to before 1.8.0 Fixed in 1.8.0 Patch available CNA
- @arikusi/deepseek-mcp-server (npm) Vendor— Affected 1.4.2 to before 1.8.0 Fixed in 1.8.0 Patch available GHSA-72f3-6w86-7rv3
Remediation
- Fix · CNA deepseek-mcp-server (arikusi) Fixed in 1.8.0
- Fix · GHSA-72f3-6w86-7rv3 @arikusi/deepseek-mcp-server (npm) Fixed in 1.8.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-55605
- 2026-10-03 Alias added: GHSA-72f3-6w86-7rv3
References
Other 6
- https://github.com/arikusi/deepseek-mcp-server/security/advisories/GHSA-72f3-6w86-7rv3
- https://github.com/arikusi/deepseek-mcp-server/blob/main/CHANGELOG.md#180---2026-06-14
- https://github.com/arikusi/deepseek-mcp-server/releases/tag/v1.8.0
- https://github.com/arikusi/deepseek-mcp-server/pull/4
- https://github.com/arikusi/deepseek-mcp-server/commit/dab07ed93ddde0ab219d4cb7066785847db53a32
- https://github.com/arikusi/deepseek-mcp-server
More arikusi vulnerabilities
- TI-2026-40138 @arikusi/deepseek-mcp-server has an Authorization Bypass Through User-Controlled Key CVSS 3.1HIGH 8.6
Sources
- CVE-2026-55605 · CVE Program
- CVE-2026-55605 · NVD
- FIRST EPSS
- GHSA-72f3-6w86-7rv3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences