Read the docs
TI-2026-40316 Aliases CVE-2026-55855GHSA-g5xc-5w98-jfvm

Improper output encoding in mariadb-connector-nodejs

Priority LOW 30CWE-116Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
SQL injection
Confidentiality · integrity · availability
High · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. Prior to 3.2.4, 3.3.3, 3.4.6, and 3.5.3, MariaDB Connector/Node.js permits SQL injection when attacker-controlled Buffer parameters are escaped client-side under the big5, gbk, sjis, cp932, or gb18030 client character sets. PacketOutputStream.writeBufferEscape in lib/io/packet-output-stream.js escaped bytes without the charset-aware getMbRecognizer logic in lib/misc/charset-mb.js. The server SQL lexer runs my_ismbchar before escape processing, so an attacker-controlled lead byte can consume the inserted 0x5C backslash as a multibyte trail byte and leave the following 0x27 quote unescaped, terminating the string literal and allowing arbitrary SQL. The default utf8mb4 character set and parameters sent through the execute binary prepared-statement path are not affected. Successful exploitation can expose or modify data available to the database account. This issue is fixed in versions 3.2.4, 3.3.3, 3.4.6, and 3.5.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00692 53rd percentileScored 2026-11-07
Fix Fixed mariadb-connector-nodejs (mariadb-corporation): 3.2.4, 3.3.3, 3.4.6 +1mariadb (npm): 3.2.4, 3.3.4, 3.4.6 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MariaDBmariadb-connector-nodejsbefore 3.2.4; 3.3.0 to before 3.3.3; 3.4.0 to before 3.4.6; 3.5.0 to before 3.5.33.2.4, 3.3.3, 3.4.6, 3.5.3Patch availableCNA
—mariadb (npm)before 3.2.43.2.4Patch availableGHSA-g5xc-5w98-jfvm
—mariadb (npm)3.3.0 to before 3.3.43.3.4Patch availableGHSA-g5xc-5w98-jfvm
—mariadb (npm)3.4.0 to before 3.4.63.4.6Patch availableGHSA-g5xc-5w98-jfvm
—mariadb (npm)3.5.0 to before 3.5.33.5.3Patch availableGHSA-g5xc-5w98-jfvm
  • mariadb-connector-nodejs VendorMariaDB Affected before 3.2.4; 3.3.0 to before 3.3.3; 3.4.0 to before 3.4.6; 3.5.0 to before 3.5.3 Fixed in 3.2.4, 3.3.3, 3.4.6, 3.5.3 Patch available CNA
  • mariadb (npm) Vendor— Affected before 3.2.4 Fixed in 3.2.4 Patch available GHSA-g5xc-5w98-jfvm
  • mariadb (npm) Vendor— Affected 3.3.0 to before 3.3.4 Fixed in 3.3.4 Patch available GHSA-g5xc-5w98-jfvm
  • mariadb (npm) Vendor— Affected 3.4.0 to before 3.4.6 Fixed in 3.4.6 Patch available GHSA-g5xc-5w98-jfvm
  • mariadb (npm) Vendor— Affected 3.5.0 to before 3.5.3 Fixed in 3.5.3 Patch available GHSA-g5xc-5w98-jfvm

Remediation

  • Fix · CNA mariadb-connector-nodejs (mariadb-corporation) Fixed in 3.2.4, 3.3.3, 3.4.6, 3.5.3
  • Fix · GHSA-g5xc-5w98-jfvm mariadb (npm) Fixed in 3.2.4 Advisory →
  • Fix · GHSA-g5xc-5w98-jfvm mariadb (npm) Fixed in 3.3.4 Advisory →
  • Fix · GHSA-g5xc-5w98-jfvm mariadb (npm) Fixed in 3.4.6 Advisory →
  • Fix · GHSA-g5xc-5w98-jfvm mariadb (npm) Fixed in 3.5.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-55855
  2. 2026-10-03 Alias added: GHSA-g5xc-5w98-jfvm
  3. 2026-10-13 EPSS moved to the 50th–90th percentile

References

  • TI-2023-11776 MariaDB v10.5 was discovered to contain a remote code execution (RCE) vulnerability via… CVSS 3.1CRITICAL 9.8
  • TI-2016-05707 Oracle MySQL through 5.5.52, 5.6.x through 5.6.33, and 5.7.x through 5.7.15; MariaDB… CVSS 3.0CRITICAL 9.8
  • TI-2022-00687 Infinite loop in BN_mod_sqrt() reachable when parsing certificates CVSS 3.1HIGH 7.5
  • TI-2014-00217 OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly… CVSS 3.1HIGH 7.4
  • TI-2014-00188 The dtls1_reassemble_fragment function in d1_both.c in OpenSSL before 0.9.8za, 1.0.0… CVSS 2.0MEDIUM 6.8
  • TI-2018-15259 zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if… CVSS 3.1HIGH 7.5
See all 459 →

Sources