Users API leaks whether privileged users have their user groups disabled for lack of 2FA
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/Api/ApiQueryAllUsers.Php, includes/Api/ApiQueryUsers.Php, includes/Permissions/PermissionManager.Php, includes/User/UserGroupManager.Php.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | MediaWiki | 1.46.0-rc.0 to before 1.46.0 | 1.46.0 | Patch available | CNA |
- MediaWiki VendorWikimedia Foundation Affected 1.46.0-rc.0 to before 1.46.0 Fixed in 1.46.0 Patch available CNA
Remediation
- Fix · CNA MediaWiki (Wikimedia Foundation) Fixed in 1.46.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Wikimedia Foundation MediaWiki 1.46.0
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2026-41790 Stored XSS through a system message in the codex version of Special:BlockPriority LOW 3
- TI-2026-41786 Stored i18n XSS in Special:ApiSandbox when a deprecated module is selectedPriority LOW 2
Timeline
- 2026-10-02 Threatist record created from CVE-2026-58036
- 2026-10-03 Alias added: GHSA-qf2r-x8qv-xrwx
References
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2026-58036 · CVE Program
- CVE-2026-58036 · NVD
- FIRST EPSS
- GHSA-qf2r-x8qv-xrwx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences