Anki: User scripts in iframes have access to the internal Anki API
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-346.
Summary
Anki is a program for creating and reviewing flashcards. Prior to 25.09.4, Anki's webview-based pages communicate with the Rust backend using an internal localhost API, and user scripts included via iframes in the editor can access this API despite protections intended to block reviewer and editor scripts. A malicious imported card package with an embedded iframe can use exposed API methods such as getImageForOcclusion to read arbitrary files accessible to the Anki process and exfiltrate them over the network. This issue is fixed in version 25.09.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA anki (ankitects) Fixed in 25.09.4
Timeline
- 2026-10-02 Threatist record created from CVE-2026-58266
References
More Ankitects vulnerabilities
- TI-2024-17117 Injection in Ankitects Anki CVSS 3.1CRITICAL 9.6
- TI-2024-21378 Cross-site scripting in Ankitects Anki CVSS 3.1HIGH 8.2
- TI-2024-19251 An vulnerability in the handling of Latex exists in Ankitects Anki 24.04. CVSS 3.1MEDIUM 6.5
- TI-2024-21226 A blocklist bypass vulnerability exists in the LaTeX functionality of Ankitects Anki… CVSS 3.1MEDIUM 4.3
- TI-2025-38504 Ankitects Anki before 25.02.5 allows a crafted shared deck on Windows to execute… CVSS 3.1HIGH 7.8
- TI-2025-38503 Uncontrolled search path in Ankitects Anki CVSS 3.1HIGH 7.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences