Blocked users can create and edit WikiLambda objects
Priority LOW 36CWE-288Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-288.
Summary
Improper neutralization of input terminators vulnerability in The Wikimedia Foundation Mediawiki - WikiLambda Extension allows Authentication Bypass. This issue affects Mediawiki - WikiLambda Extension: from * before 1.43.9,1.44.6,1.45.4.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00329 26th percentileScored 2026-11-07
Fix Fixed Mediawiki - WikiLambda Extension (The Wikimedia Foundation): 1.43.9,1.44.6,1.45.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | Mediawiki - WikiLambda Extension | before 1.43.9,1.44.6,1.45.4 | 1.43.9,1.44.6,1.45.4 | Patch available | CNA |
- Mediawiki - WikiLambda Extension VendorWikimedia Foundation Affected before 1.43.9,1.44.6,1.45.4 Fixed in 1.43.9,1.44.6,1.45.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* | 1.43.0 to before 1.43.9; 1.44.0 to before 1.44.6; 1.45.0 to before 1.45.4 | Vulnerable | mediawiki |
- cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.43.0 to before 1.43.9; 1.44.0 to before 1.44.6; 1.45.0 to before 1.45.4 Vulnerable ·mediawiki
Remediation
- Fix · CNA Mediawiki - WikiLambda Extension (The Wikimedia Foundation) Fixed in 1.43.9,1.44.6,1.45.4
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-58517
- 2026-10-03 Alias added: GHSA-9r5v-wvvq-6v9f
References
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2026-58517 · CVE Program
- CVE-2026-58517 · NVD
- FIRST EPSS
- GHSA-9r5v-wvvq-6v9f · GitHub Advisory Database · CC BY 4.0
- CVE-2026-58517 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences