LobeChat < 2.2.10-canary.15 - Regular Expression Denial of Service in GitHub Skill Import
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-1333.
Summary
LobeChat before version 2.2.10-canary.15 contains a regular expression denial of service (ReDoS) vulnerability that allows authenticated attackers to block the Node.js event loop by supplying a catastrophic-backtracking pattern in a GitHub repository URL path during skill import. Attackers can craft a malicious basePath value containing unescaped regex metacharacters such as catastrophic-backtracking patterns, which are injected into a dynamically constructed regular expression in the findSkillMd function and executed synchronously against archive entries, denying service to all concurrent users for tens of seconds per request.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA lobehub (lobehub) Fixed in 2.2.10-canary.15
Timeline
- 2026-10-02 Threatist record created from CVE-2026-58578
- 2026-10-03 Alias added: GHSA-g4jq-25cx-3cw5
References
More lobehub vulnerabilities
- TI-2026-39067 LobeHub: Unauthenticated SSRF in `/webapi/proxy` CVSS 3.1CRITICAL 9.0
- TI-2026-83681 Path traversal in LobeHub Chat lets users write arbitrary files CVSS 4.0HIGH 8.7
- TI-2024-31448 Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964) CVSS 3.1CRITICAL 9.0
- TI-2024-21831 lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability CVSS 3.1CRITICAL 9.0
- TI-2026-58746 LobeChat 2.2.1 Webhook Signature Verification Bypass QQ Feishu CVSS 4.0MEDIUM 6.9
- TI-2024-21832 ssrf vulnerability in lobe-chat CVSS 3.1HIGH 8.6
Sources
- CVE-2026-58578 · CVE Program
- CVE-2026-58578 · NVD
- FIRST EPSS
- GHSA-g4jq-25cx-3cw5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences