Image::WebP versions before 0.3.0 for Perl bundle a vulnerable version of libwebp
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
Image::WebP versions before 0.3.0 for Perl bundle a vulnerable version of libwebp. Image::WebP does not link to the system libwebp. Instead, it uses a bundled copy of libwebp 0.3.0 (released 2013-03-20). That version has multiple known vulnerabilities, including CVE-2023-4863. Any caller that decodes an untrusted WebP image reaches the bundled decoder. Because the library is compiled into the module, upgrading the system libwebp does not remediate this.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Image::WebP (ZAPAD) Fixed in 0.3.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-58586
- 2026-10-03 Alias added: GHSA-7qv8-435q-f6x2
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2026-58586 · CVE Program
- CVE-2026-58586 · NVD
- FIRST EPSS
- GHSA-7qv8-435q-f6x2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences