Read the docs
TI-2026-42319 Aliases CVE-2026-59153GHSA-869j-r97x-hx2g

Anki's local HTTP server does not sufficiently validate requests

Priority LOW 11CWE-346Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Active
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-346.

Summary

Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, Anki launches a local HTTP server to serve media files and web pages for parts of its interface, but requests from other origins were not sufficiently blocked. A malicious website could potentially trigger side-effecting requests to the local server, with severity varying by browser depending on Private Network Access protections. This issue is fixed in version 25.09.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00264 18th percentileScored 2026-11-07
Fix Fixed anki (ankitects): 25.09.3aqt (PyPI): 25.9.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Ankitectsankibefore 25.09.325.09.3Patch availableCNA
—aqt (PyPI)before 25.9.325.9.3Patch availableGHSA-869j-r97x-hx2g
  • anki VendorAnkitects Affected before 25.09.3 Fixed in 25.09.3 Patch available CNA
  • aqt (PyPI) Vendor— Affected before 25.9.3 Fixed in 25.9.3 Patch available GHSA-869j-r97x-hx2g

Remediation

  • Fix · CNA anki (ankitects) Fixed in 25.09.3
  • Fix · GHSA-869j-r97x-hx2g aqt (PyPI) Fixed in 25.9.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-59153
  2. 2026-10-03 Alias added: GHSA-869j-r97x-hx2g

References

  • TI-2024-17117 Injection in Ankitects Anki CVSS 3.1CRITICAL 9.6
  • TI-2024-21378 Cross-site scripting in Ankitects Anki CVSS 3.1HIGH 8.2
  • TI-2024-19251 An vulnerability in the handling of Latex exists in Ankitects Anki 24.04. CVSS 3.1MEDIUM 6.5
  • TI-2024-21226 A blocklist bypass vulnerability exists in the LaTeX functionality of Ankitects Anki… CVSS 3.1MEDIUM 4.3
  • TI-2025-38504 Ankitects Anki before 25.02.5 allows a crafted shared deck on Windows to execute… CVSS 3.1HIGH 7.8
  • TI-2025-38503 Uncontrolled search path in Ankitects Anki CVSS 3.1HIGH 7.8
See all 10 →

Sources