Composer: CVE-2026-59946 fix bypass via symlinked package bin path
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
Composer is a dependency Manager for the PHP language. From 1.0 until 2.2.30 and from 2.3.0 until 2.10.3, a malicious or compromised dependency can bypass the earlier CVE-2026-59946 binary-path hardening because Composer validates literal parent-directory segments only during dependency resolution, while the symlink and installed-metadata paths described by the advisory skip that validation. A package can ship an in-package binary symlink that resolves outside its installation directory, or attacker-influenced vendor/composer/installed.json metadata can provide an escaping binary path during a reinstall or regeneration of missing vendor/bin entries. The installed-metadata path is reachable only when the vendor directory was not populated by the same validated install run, such as when it is restored from an untrusted cache, copied from an earlier build stage, carried over from an older Composer run, or writable by a lower-trust build step. Composer can follow the path, change the external target's permissions to make it world-readable and executable, and create a runnable vendor/bin proxy to that external file. The issue does not directly read or transmit data and does not by itself provide remote code execution. This issue is fixed in versions 2.2.30 and 2.10.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| composer | composer | 1.0.0 to before 2.2.30; 2.3.0 to before 2.10.3 | 2.2.30, 2.10.3 | Patch available | CNA |
| — | composer/composer (Packagist) | 2.3.0 to before 2.10.3 | 2.10.3 | Patch available | GHSA-96h3-5x6v-m776 |
| — | composer/composer (Packagist) | 1.0 to before 2.2.30 | 2.2.30 | Patch available | GHSA-96h3-5x6v-m776 |
- composer Vendorcomposer Affected 1.0.0 to before 2.2.30; 2.3.0 to before 2.10.3 Fixed in 2.2.30, 2.10.3 Patch available CNA
- composer/composer (Packagist) Vendor— Affected 2.3.0 to before 2.10.3 Fixed in 2.10.3 Patch available GHSA-96h3-5x6v-m776
- composer/composer (Packagist) Vendor— Affected 1.0 to before 2.2.30 Fixed in 2.2.30 Patch available GHSA-96h3-5x6v-m776
Remediation
- Fix · CNA composer (composer) Fixed in 2.2.30, 2.10.3
- Fix · GHSA-96h3-5x6v-m776 composer/composer (Packagist) Fixed in 2.10.3 Advisory →
- Fix · GHSA-96h3-5x6v-m776 composer/composer (Packagist) Fixed in 2.2.30 Advisory →
Red Hat 1 advisory
- RHSA-2026:63151 Released 2026-09-03 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images composer-2.10.3-1.hum1@noarch@public-hummingbird-aarch64-rpms, composer-2.10.3-1.hum1@noarch@public-hummingbird-x86_64-rpms, composer-2.10.3-1.hum1@src
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Hardened Images | Fixed | RHSA-2026:63151 |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-59944
- 2026-10-03 Alias added: GHSA-96h3-5x6v-m776
References
Other 6
- https://github.com/composer/composer/security/advisories/GHSA-96h3-5x6v-m776
- https://github.com/composer/composer/commit/53b8bb4c24697b2f00a18cf1ef35a10392701b89
- https://github.com/composer/composer/commit/ad649fdfdf8ed826d4a34e0e5690c76a0b4833aa
- https://github.com/composer/composer/releases/tag/2.10.3
- https://github.com/composer/composer/releases/tag/2.2.30
- https://github.com/composer/composer
More composer vulnerabilities
- TI-2015-06892 Composer before 2016-02-10 allows cache poisoning from other projects built on the same… CVSS 3.1HIGH 8.8
- TI-2021-17955 Command injection in composer on Windows CVSS 3.1CRITICAL 9.8
- TI-2024-23311 Composer vulnerable to command injection via malicious git/hg branch names CVSS 3.1HIGH 8.8
- TI-2021-10185 Code injection in composer CVSS 3.1HIGH 8.8
- TI-2022-08641 Missing input validation can lead to command execution in composer CVSS 3.1HIGH 8.8
- TI-2026-29055 Composer has Command Injection via Malicious Perforce Reference CVSS 3.1HIGH 8.8
Sources
- CVE-2026-59944 · CVE Program
- CVE-2026-59944 · NVD
- FIRST EPSS
- GHSA-96h3-5x6v-m776 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-59944 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences