Incorrect authorization in jhb-software payload-plugins
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Payload Plugins is a collection of plugins designed to enhance Payload CMS. In 0.7.0, @jhb.software/payload-alt-text-plugin exposes POST /api/alt-text-plugin/generate and POST /api/alt-text-plugin/bulk with a default guard that accepts any authenticated user, while alt-text/src/endpoints/generateAltText.ts and alt-text/src/endpoints/bulkGenerateAltTexts.ts call req.payload.findByID and req.payload.update without overrideAccess: false. Payload therefore defaults overrideAccess to true and skips the target collection's read and update access functions. An authenticated low-privilege user can supply id, collection, locale, and update values to read arbitrary protected upload documents and overwrite their alt and keywords fields, even when the collection permits those operations only to administrators. A control Local API call with overrideAccess: false is denied, confirming that the plugin endpoint bypasses otherwise effective collection rules. This vulnerability is fixed in 0.8.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jhb-software | payload-plugins | before 0.8.0 | 0.8.0 | Patch available | CNA |
| jhb-software | payload-alt-text-plugin | before 0.8.0 | 0.8.0 | Patch available | CNA |
| — | @jhb.software/payload-alt-text-plugin (npm) | before 0.8.0 | 0.8.0 | Patch available | GHSA-4qpv-39hg-f7fx |
- payload-plugins Vendorjhb-software Affected before 0.8.0 Fixed in 0.8.0 Patch available CNA
- payload-alt-text-plugin Vendorjhb-software Affected before 0.8.0 Fixed in 0.8.0 Patch available CNA
- @jhb.software/payload-alt-text-plugin (npm) Vendor— Affected before 0.8.0 Fixed in 0.8.0 Patch available GHSA-4qpv-39hg-f7fx
Remediation
- Fix · CNA payload-plugins (jhb-software) Fixed in 0.8.0
- Fix · CNA payload-alt-text-plugin (@jhb.software) Fixed in 0.8.0
- Fix · GHSA-4qpv-39hg-f7fx @jhb.software/payload-alt-text-plugin (npm) Fixed in 0.8.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-59965
- 2026-10-03 Alias added: GHSA-4qpv-39hg-f7fx
References
Other 5
- https://github.com/jhb-software/payload-plugins/security/advisories/GHSA-4qpv-39hg-f7fx
- https://github.com/jhb-software/payload-plugins/pull/159
- https://github.com/jhb-software/payload-plugins/commit/e39634868ce13a414e2981e219befc58101654d3
- https://github.com/jhb-software/payload-plugins/releases/tag/[email protected]
- https://github.com/jhb-software/payload-plugins
More jhb-software vulnerabilities
- TI-2026-41914 @jhb.software/payload-cloudinary-plugin: Arbitrary Cloudinary API Parameter Signing CVSS 3.1HIGH 7.1
Sources
- CVE-2026-59965 · CVE Program
- CVE-2026-59965 · NVD
- FIRST EPSS
- GHSA-4qpv-39hg-f7fx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences