NGINX Agent Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
The NGINX Agent config_dirs directive allows a low-privileged attacker to gain limited read and write access to files outside of the designated secure directory. The config_dirs directive required for this issue can also be configured through NGINX Instance Manager. A successful exploit may allow an attacker to cross a security boundary. Impact: A remotely authenticated low-privileged attacker could gain limited read and write access outside of the list of directories specified in the NGINX Agent configuration. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| F5 | NGINX Agent | 2.0.0 to before 2.47.0 | 3.0.0, 2.47.0 | Patch available | CNA |
| F5 | NGINX Instance Manager | 2.22.0 to before 2.22.2; 2.17.1 and later | 2.22.2 | Patch available | CNA |
Remediation
- Fix · CNA NGINX Agent (F5) Fixed in 3.0.0, 2.47.0
- Fix · CNA NGINX Instance Manager (F5) Fixed in 2.22.2
Timeline
- 2026-10-02 Threatist record created from CVE-2026-60062
- 2026-10-03 Alias added: GHSA-66rh-w67w-7426
References
More F5 Nginx Agent vulnerabilities
- TI-2024-07074 NGINX Agent Vulnerability CVSS 4.0MEDIUM 6.9
- TI-2023-01464 NGINX Agent vulnerability CVE-2023-1550 CVSS 3.1MEDIUM 5.5
Sources
- CVE-2026-60062 · CVE Program
- CVE-2026-60062 · NVD
- FIRST EPSS
- GHSA-66rh-w67w-7426 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences