libp2p-quic: Remote panic via certificate expiry race during QUIC handshake
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-248.
Summary
libp2p-rust is the official Rust language implementation of the libp2p networking stack. Prior to 0.13.1, libp2p-quic could panic during an inbound QUIC handshake when a remote peer presented a valid short-lived libp2p TLS certificate and delayed the final TLS 1.3 handshake fragment until after the certificate expired. In the Quinn post-handshake upgrade path, transports/quic/src/connection/connecting.rs called libp2p_tls::certificate::parse a second time in remote_peer_id and used expect on the result. The repeated wall-clock validity check could reject the now-expired certificate, causing the expect call to terminate any application exposing an affected libp2p-quic listener. This vulnerability is fixed in 0.13.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| libp2p | rust-libp2p | before 0.13.1 | 0.13.1 | Patch available | CNA |
| — | libp2p-quic (crates.io) | before 0.13.1 | 0.13.1 | Patch available | GHSA-5hq8-qhww-jm7q |
- rust-libp2p Vendorlibp2p Affected before 0.13.1 Fixed in 0.13.1 Patch available CNA
- libp2p-quic (crates.io) Vendor— Affected before 0.13.1 Fixed in 0.13.1 Patch available GHSA-5hq8-qhww-jm7q
Remediation
- Fix · CNA rust-libp2p (libp2p) Fixed in 0.13.1
- Fix · GHSA-5hq8-qhww-jm7q libp2p-quic (crates.io) Fixed in 0.13.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-61544
- 2026-10-03 Alias added: GHSA-5hq8-qhww-jm7q
References
Other 5
- https://github.com/libp2p/rust-libp2p/security/advisories/GHSA-5hq8-qhww-jm7q
- https://github.com/libp2p/rust-libp2p/pull/6525
- https://github.com/libp2p/rust-libp2p/commit/212f3774af048e2cecfb2e6b1e08477685e52b22
- https://github.com/libp2p/rust-libp2p/commit/e8f35e12c2418b04df6e9cdf036005e8aee3c7a2
- https://github.com/libp2p/rust-libp2p
More libp2p vulnerabilities
- TI-2026-60386 libp2p-rendezvous through 0.17.1 Denial of Service via Unbounded Registration TTL in Discovery Responses CVSS 4.0HIGH 8.7
- TI-2026-58865 libp2p: PeerStore accepts attacker-signed PeerRecords for a victim peer ID and stores certified attacker addresses CVSS 3.1HIGH 8.2
- TI-2026-27587 libp2p-rust has unbounded rendezvous DISCOVER cookies enable remote memory exhaustion CVSS 3.1HIGH 8.2
- TI-2026-58864 libp2p: Gossipsub StrictSign accepts attacker-signed messages as a victim RSA peer ID CVSS 3.1HIGH 7.5
- TI-2026-53982 libp2p: Circuit relay v2 server reservation refresh leaks abort listeners and allows remote resource exhaustion CVSS 3.1HIGH 7.5
- TI-2026-51658 py-libp2p: yamux connection DoS via oversized data frame CVSS 3.1HIGH 7.5
Sources
- CVE-2026-61544 · CVE Program
- CVE-2026-61544 · NVD
- FIRST EPSS
- GHSA-5hq8-qhww-jm7q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences