MPXJ: XXE Vulnerability in MerlinReader
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-611 and the CVSS impact.
Summary
MPXJ is an open source library to read and write project plans from a variety of file formats and databases. From 5.5.5 until 16.4.1, MerlinReader creates a DocumentBuilder with default settings while parsing XML from the ZTIMEINTERVALS column of a Merlin project SQLite database, leaving doctype declarations and external entities enabled. A crafted database can cause the parser to read an arbitrary local file, although MPXJ's subsequent handling of the parsed XML makes disclosure of the file contents unlikely. This issue is fixed in version 16.4.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| joniles | mpxj | 5.5.5 to before 16.4.1 | 16.4.1 | Patch available | CNA |
| — | net.sf.mpxj:mpxj (Maven) | 5.5.5 to before 16.4.1 | 16.4.1 | Patch available | GHSA-5vvx-3h34-f3gj |
| — | mpxj (RubyGems) | 5.5.5 to before 16.4.1 | 16.4.1 | Patch available | GHSA-5vvx-3h34-f3gj |
| — | MPXJ.Net (NuGet) | 5.5.5 to before 16.4.1 | 16.4.1 | Patch available | GHSA-5vvx-3h34-f3gj |
| — | net.sf.mpxj (NuGet) | 5.5.5 to before 16.4.1 | 16.4.1 | Patch available | GHSA-5vvx-3h34-f3gj |
| — | net.sf.mpxj-for-csharp (NuGet) | 5.5.5 to before 16.4.1 | 16.4.1 | Patch available | GHSA-5vvx-3h34-f3gj |
| — | net.sf.mpxj-for-vb (NuGet) | 5.5.5 to before 16.4.1 | 16.4.1 | Patch available | GHSA-5vvx-3h34-f3gj |
| — | mpxj (PyPI) | 5.5.5 to before 16.4.1 | 16.4.1 | Patch available | GHSA-5vvx-3h34-f3gj |
- mpxj Vendorjoniles Affected 5.5.5 to before 16.4.1 Fixed in 16.4.1 Patch available CNA
- net.sf.mpxj:mpxj (Maven) Vendor— Affected 5.5.5 to before 16.4.1 Fixed in 16.4.1 Patch available GHSA-5vvx-3h34-f3gj
- mpxj (RubyGems) Vendor— Affected 5.5.5 to before 16.4.1 Fixed in 16.4.1 Patch available GHSA-5vvx-3h34-f3gj
- MPXJ.Net (NuGet) Vendor— Affected 5.5.5 to before 16.4.1 Fixed in 16.4.1 Patch available GHSA-5vvx-3h34-f3gj
- net.sf.mpxj (NuGet) Vendor— Affected 5.5.5 to before 16.4.1 Fixed in 16.4.1 Patch available GHSA-5vvx-3h34-f3gj
- net.sf.mpxj-for-csharp (NuGet) Vendor— Affected 5.5.5 to before 16.4.1 Fixed in 16.4.1 Patch available GHSA-5vvx-3h34-f3gj
- net.sf.mpxj-for-vb (NuGet) Vendor— Affected 5.5.5 to before 16.4.1 Fixed in 16.4.1 Patch available GHSA-5vvx-3h34-f3gj
- mpxj (PyPI) Vendor— Affected 5.5.5 to before 16.4.1 Fixed in 16.4.1 Patch available GHSA-5vvx-3h34-f3gj
Remediation
- Fix · CNA mpxj (joniles) Fixed in 16.4.1
- Fix · GHSA-5vvx-3h34-f3gj net.sf.mpxj:mpxj (Maven) Fixed in 16.4.1 Advisory →
- Fix · GHSA-5vvx-3h34-f3gj mpxj (RubyGems) Fixed in 16.4.1 Advisory →
- Fix · GHSA-5vvx-3h34-f3gj MPXJ.Net (NuGet) Fixed in 16.4.1 Advisory →
- Fix · GHSA-5vvx-3h34-f3gj net.sf.mpxj (NuGet) Fixed in 16.4.1 Advisory →
- Fix · GHSA-5vvx-3h34-f3gj net.sf.mpxj-for-csharp (NuGet) Fixed in 16.4.1 Advisory →
- Fix · GHSA-5vvx-3h34-f3gj net.sf.mpxj-for-vb (NuGet) Fixed in 16.4.1 Advisory →
- Fix · GHSA-5vvx-3h34-f3gj mpxj (PyPI) Fixed in 16.4.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-61570
- 2026-10-03 Alias added: GHSA-5vvx-3h34-f3gj
References
More joniles vulnerabilities
- TI-2024-33238 MPXJ has a Potential Path Traversal Vulnerability CVSS 3.1MEDIUM 5.3
- TI-2026-46908 MPXJ: Potential Path Traversal Vulnerability in Primavera P3 PRX and SureTrak STX readers CVSS 3.1MEDIUM 5.3
Sources
- CVE-2026-61570 · CVE Program
- CVE-2026-61570 · NVD
- FIRST EPSS
- GHSA-5vvx-3h34-f3gj · GitHub Advisory Database · CC BY 4.0
- CVE-2026-61570 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences