Read the docs
TI-2026-44381 Aliases CVE-2026-62105GHSA-m36j-q8jp-7wgq

WordPress ThemeREX Addons plugin < 2.45.0 - PHP Object Injection vulnerability

Priority MEDIUM 50CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.

Summary

Unauthenticated PHP Object Injection in ThemeREX Addons < 2.45.0 versions.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00564 47th percentileScored 2026-11-07
Fix Fixed ThemeREX Addons (ThemeRex): 2.45.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ThemeREXThemeREX Addonsbefore 2.45.02.45.0Patch availableCNA
  • ThemeREX Addons VendorThemeREX Affected before 2.45.0 Fixed in 2.45.0 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:themerex:addons:*:*:*:*:*:*:*:*——ThemeREX
  • cpe:2.3:a:themerex:addons:*:*:*:*:*:*:*:* Versions — — ·ThemeREX

Remediation

  • Fix · CNA ThemeREX Addons (ThemeRex) Fixed in 2.45.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-62105
  2. 2026-10-03 Alias added: GHSA-m36j-q8jp-7wgq

References

  • TI-2020-08268 The ThemeREX Addons plugin before 2020-03-09 for WordPress lacks access control on the… CVSS 3.1CRITICAL 9.8
  • TI-2024-12489 ThemeREX Addons <= 2.32.3 - Unauthenticated Arbitrary File Upload in trx_addons_uploads_save_data CVSS 3.1CRITICAL 9.8
  • TI-2024-05844 Several WordPress.org Plugins <= Various Versions - Injected Backdoor CVSS 3.1CRITICAL 10.0
  • TI-2026-47321 WordPress FreightCo theme <= 1.1.15 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2026-46741 WordPress Abelle theme <= 1.22 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2026-18035 WordPress Solaris theme <= 2.5 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
See all 237 →

Sources