Bluetooth: btnxpuart: Fix out-of-bounds firmware read in nxp_recv_fw_req_v3()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: Bluetooth: btnxpuart: Fix out-of-bounds firmware read in nxp_recv_fw_req_v3() During the v3 firmware download the controller sends a v3_data_req with a 32 bit offset and a 16 bit len. nxp_recv_fw_req_v3() checks only the lower bound of the offset and then sends firmware from that offset. nxpdev->fw_dnld_v3_offset = offset - nxpdev->fw_v3_offset_correction; serdev_device_write_buf(nxpdev->serdev, nxpdev->fw->data + nxpdev->fw_dnld_v3_offset, len); Nothing checks that fw_dnld_v3_offset + len stays within nxpdev->fw->size, so a controller that asks for an offset or length past the firmware image makes the driver read past the end of nxpdev->fw->data and send that memory back over UART. nxp_recv_fw_req_v1() already bounds the same write. Add the equivalent check to the v3 path, reject the request when it falls outside the firmware image, and zero len on the error path so the fw_v3_prev_sent bookkeeping at free_skb stays consistent.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.4 and later | 6.6.145, 6.12.96, 6.18.39, 7.1.4, 7.2 | Patch available | CNA |
- Linux VendorLinux Affected 6.4 and later Fixed in 6.6.145, 6.12.96, 6.18.39, 7.1.4, 7.2 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.4 to before 6.6.145; 6.7 to before 6.12.96; 6.13 to before 6.18.39; 6.19 to before 7.1.4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.2:rc1:*:*:*:*:*:* | 7.2 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.2:rc2:*:*:*:*:*:* | 7.2 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.4 to before 6.6.145; 6.7 to before 6.12.96; 6.13 to before 6.18.39; 6.19 to before 7.1.4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.2:rc1:*:*:*:*:*:* Versions 7.2 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.2:rc2:*:*:*:*:*:* Versions 7.2 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.6.145, 6.12.96, 6.18.39, 7.1.4, 7.2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-64407
- 2026-10-03 Alias added: GHSA-vpwp-65cp-hgqm
References
Patch 5
- https://git.kernel.org/stable/c/21e60eb4d95854196e7c0e77383f35e7ac95df61
- https://git.kernel.org/stable/c/441088792ffec3ca01f4efe2934060570eb11eb8
- https://git.kernel.org/stable/c/2a68a773089204af1c8581dc79668b775418c5ee
- https://git.kernel.org/stable/c/49bcb39e3a041ce26021f77971eaccb49a275118
- https://git.kernel.org/stable/c/badff6c3bed8923a1257a853f137d447976eec30
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-64407 · CVE Program
- CVE-2026-64407 · NVD
- FIRST EPSS
- GHSA-vpwp-65cp-hgqm · GitHub Advisory Database · CC BY 4.0
- CVE-2026-64407 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences