Cross-Site Request Forgery (CSRF) in ATutor
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
ATutor is vulnerable to Cross-Site Request Forgery (CSRF) in profile update functionality. An attacker can craft a malicious website which, when visited by an authenticated victim, submits a forged request to the system. Due to the lack of proper CSRF token implementation, the forged request is processed successfully, allowing an attacker to modify profile fields of an existing user. Product is no longer actively supported and the vulnerabilities have not been fixed. Only version 2.2.4 was tested and confirmed as vulnerable, other versions were not tested but might also be vulnerable.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-64962
- 2026-10-03 Alias added: GHSA-phq2-mj6g-pcj3
References
More ATutor vulnerabilities
- TI-2016-02300 SQL injection vulnerability in include/lib/mysql_connect.inc.php in ATutor 2.2.1 allows… CVSS 3.0CRITICAL 9.8
- TI-2019-09087 ATutor 2.2.4 allows Arbitrary File Upload and Directory Traversal, resulting in remote… CVSS 3.1HIGH 8.8
- TI-2017-14349 ATutor versions 2.2.1 and earlier are vulnerable to a directory traversal and file… CVSS 3.0CRITICAL 9.8
- TI-2020-19282 ATutor 2.2.4 - 'id' SQL Injection CVSS 4.0HIGH 7.0
- TI-2023-11865 A Cross-site scripting (XSS) vulnerability in the function encrypt_password() in… CVSS 3.1MEDIUM 6.1
- TI-2019-12106 In ATutor 2.2.4, an unauthenticated attacker can change the application settings and… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-64962 · CVE Program
- CVE-2026-64962 · NVD
- FIRST EPSS
- GHSA-phq2-mj6g-pcj3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences