An insecure Apache configuration in ConfigServer Security & Firewall maps /usr/bin as CGI…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-552.
Summary
An insecure Apache configuration in ConfigServer Security & Firewall maps /usr/bin as CGI programs through the Messenger v3 HTTPS virtual host. A remote unauthenticated attacker whose address is blocked can request a mapped executable and run arbitrary commands as the Apache user. The vulnerability affects installations where CSF Messenger v3 and its HTTPS mode are enabled. WebPros addressed the vulnerability in version 16.31.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WebPros | ConfigServer Security & Firewall | 14.02 to before 16.31 | 16.31 | Patch available | CNA |
| ConfigServer | ConfigServer Security & Firewall | 14.02 and later | — | No fix listed | CNA |
- ConfigServer Security & Firewall VendorWebPros Affected 14.02 to before 16.31 Fixed in 16.31 Patch available CNA
- ConfigServer Security & Firewall VendorConfigServer Affected 14.02 and later Fixed in — No fix listed CNA
Remediation
- Fix · CNA ConfigServer Security & Firewall (WebPros) Fixed in 16.31
Timeline
- 2026-10-02 Threatist record created from CVE-2026-67402
- 2026-10-03 Alias added: GHSA-88ch-qhvf-3vfj
References
More WebPros vulnerabilities
- TI-2026-30342 WebPros cPanel and WHM Authentication Bypass via Login Flow KEVCVSS 4.0CRITICAL 9.3
- TI-2026-46792 Eval injection in cPanel 11.138.0.0 and earlier allows remote authenticated users to execute arbitrary code as root. CVSS 4.0HIGH 8.7
- TI-2025-40383 Plesk Obsidian versions 8.0.1 through 18.0.73 are vulnerable to a Denial of Service (DoS)… CVSS 3.1HIGH 7.5
- TI-2026-23322 Incorrect privileges management and insufficient path filtering allow to read arbitrary… CVSS 3.1HIGH 8.6
- TI-2026-47685 Deserialization of untrusted data in WebPros WHMCS CVSS 4.0CRITICAL 9.3
- TI-2026-23317 Authorization bypass in WebPros Comet Backup CVSS 4.0CRITICAL 9.9
Sources
- CVE-2026-67402 · CVE Program
- CVE-2026-67402 · NVD
- FIRST EPSS
- GHSA-88ch-qhvf-3vfj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences