Read the docs
TI-2026-48264 Aliases CVE-2026-68489GHSA-vqcw-x7vm-9wwm

Static Code Injection in Plesk extensions "Ruby" before 1.6.6 and "Node.js Toolkit"…

Priority MEDIUM 41CWE-96Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

Static Code Injection in Plesk extensions "Ruby" before 1.6.6 and "Node.js Toolkit" before 2.5.0 allows remote authenticated users to execute arbitrary code as root via custom environment variables.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00674 52nd percentileScored 2026-11-07
Fix Fixed Plesk extension "Ruby" (WebPros): 1.6.6Plesk extension "Node.js Toolkit" (WebPros): 2.5.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
WebProsPlesk extension "Ruby"before 1.6.61.6.6Patch availableCNA
WebProsPlesk extension "Node.js Toolkit"before 2.5.02.5.0Patch availableCNA
  • Plesk extension "Ruby" VendorWebPros Affected before 1.6.6 Fixed in 1.6.6 Patch available CNA
  • Plesk extension "Node.js Toolkit" VendorWebPros Affected before 2.5.0 Fixed in 2.5.0 Patch available CNA

Remediation

  • Fix · CNA Plesk extension "Ruby" (WebPros) Fixed in 1.6.6
  • Fix · CNA Plesk extension "Node.js Toolkit" (WebPros) Fixed in 2.5.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-68489
  2. 2026-10-03 Alias added: GHSA-vqcw-x7vm-9wwm

References

  • TI-2026-30342 WebPros cPanel and WHM Authentication Bypass via Login Flow KEVCVSS 4.0CRITICAL 9.3
  • TI-2026-46792 Eval injection in cPanel 11.138.0.0 and earlier allows remote authenticated users to execute arbitrary code as root. CVSS 4.0HIGH 8.7
  • TI-2025-40383 Plesk Obsidian versions 8.0.1 through 18.0.73 are vulnerable to a Denial of Service (DoS)… CVSS 3.1HIGH 7.5
  • TI-2026-23322 Incorrect privileges management and insufficient path filtering allow to read arbitrary… CVSS 3.1HIGH 8.6
  • TI-2026-47685 Deserialization of untrusted data in WebPros WHMCS CVSS 4.0CRITICAL 9.3
  • TI-2026-23317 Authorization bypass in WebPros Comet Backup CVSS 4.0CRITICAL 9.9
See all 50 →

Sources