Kirby: System path exposure from error messages in the REST API
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-497.
Summary
Kirby is an open-source content management system. Prior to 4.9.5 and from 5.0.0 through 5.5.1, the REST API error handler can return unsanitized PHP error messages that expose the full filesystem path of the Kirby installation to unauthenticated API users. This vulnerability affects all Kirby sites that have not disabled the REST API with the 'api' => false option. This issue is fixed in versions 4.9.5 and 5.5.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getkirby | kirby | before 4.9.5; 5.0.0 to before 5.5.2 | 4.9.5, 5.5.2 | Patch available | CNA |
| — | getkirby/cms (Packagist) | before 4.9.5 | 4.9.5 | Patch available | GHSA-rf2p-vh74-7vvh |
| — | getkirby/cms (Packagist) | 5.0.0 to before 5.5.2 | 5.5.2 | Patch available | GHSA-rf2p-vh74-7vvh |
- kirby Vendorgetkirby Affected before 4.9.5; 5.0.0 to before 5.5.2 Fixed in 4.9.5, 5.5.2 Patch available CNA
- getkirby/cms (Packagist) Vendor— Affected before 4.9.5 Fixed in 4.9.5 Patch available GHSA-rf2p-vh74-7vvh
- getkirby/cms (Packagist) Vendor— Affected 5.0.0 to before 5.5.2 Fixed in 5.5.2 Patch available GHSA-rf2p-vh74-7vvh
Remediation
- Fix · CNA kirby (getkirby) Fixed in 4.9.5, 5.5.2
- Fix · GHSA-rf2p-vh74-7vvh getkirby/cms (Packagist) Fixed in 4.9.5 Advisory →
- Fix · GHSA-rf2p-vh74-7vvh getkirby/cms (Packagist) Fixed in 5.5.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-69127
- 2026-10-03 Alias added: GHSA-rf2p-vh74-7vvh
- 2026-10-19 EPSS moved to the 50th–90th percentile
References
More getkirby vulnerabilities
- TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
- TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
- TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
- TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
- TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
- TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
Sources
- CVE-2026-69127 · CVE Program
- CVE-2026-69127 · NVD
- FIRST EPSS
- GHSA-rf2p-vh74-7vvh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences