Microsoft PowerShell Security Feature Bypass Vulnerability
Priority LOW 36CWE-94Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from Microsoft.
Summary
Improper control of generation of code ('code injection') in Microsoft PowerShell allows an unauthorized attacker to bypass a security feature locally.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00359 29th percentileScored 2026-11-07
Fix Fixed PowerShell 7.4 (Microsoft): 7.4.19.0PowerShell 7.5 (Microsoft): 7.5.10.0+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Microsoft | PowerShell 7.4 | 7.4.0 to before 7.4.19.0 | 7.4.19.0 | Patch available | CNA |
| Microsoft | PowerShell 7.5 | 7.5.0 to before 7.5.10.0 | 7.5.10.0 | Patch available | CNA |
| Microsoft | PowerShell 7.6 | 7.6.0 to before 7.6.5 | 7.6.5 | Patch available | CNA |
- PowerShell 7.4 VendorMicrosoft Affected 7.4.0 to before 7.4.19.0 Fixed in 7.4.19.0 Patch available CNA
- PowerShell 7.5 VendorMicrosoft Affected 7.5.0 to before 7.5.10.0 Fixed in 7.5.10.0 Patch available CNA
- PowerShell 7.6 VendorMicrosoft Affected 7.6.0 to before 7.6.5 Fixed in 7.6.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:microsoft:powershell:*:*:*:*:*:*:*:* | 7.4 to before 7.4.19.0; 7.5 to before 7.5.10.0; 7.6 to before 7.6.5 | Vulnerable | Microsoft |
- cpe:2.3:a:microsoft:powershell:*:*:*:*:*:*:*:* Versions 7.4 to before 7.4.19.0; 7.5 to before 7.5.10.0; 7.6 to before 7.6.5 Vulnerable ·Microsoft
Remediation
- Fix · CNA PowerShell 7.4 (Microsoft) Fixed in 7.4.19.0
- Fix · CNA PowerShell 7.5 (Microsoft) Fixed in 7.5.10.0
- Fix · CNA PowerShell 7.6 (Microsoft) Fixed in 7.6.5
Vendor assessments
Microsoft
Microsoft's page for this CVE →
- Impact
- Security Feature Bypass
- Exploited
- No
- Publicly disclosed
- No
- Exploitability
- Exploitation Less Likely
| Product | Status | Plan or fix |
|---|---|---|
| PowerShell 7.4 | Fixed | 7.4.19.0 Security Update |
| PowerShell 7.5 | Fixed | 7.5.10.0 Security Update |
| PowerShell 7.6 | Fixed | 7.6.5 Security Update |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-70338
- 2026-10-03 Alias added: GHSA-mh62-3vqg-v8vm
References
More Microsoft Powershell vulnerabilities
- TI-2024-14152 .NET and Visual Studio Denial of Service Vulnerability CVSS 3.1HIGH 7.5
- TI-2022-19606 PowerShell Remote Code Execution Vulnerability CVSS 3.1HIGH 8.5
- TI-2018-06024 A remote code execution vulnerability exists in PowerShell Editor Services, aka… CVSS 3.1CRITICAL 9.8
- TI-2024-00056 NET, .NET Framework, and Visual Studio Security Feature Bypass Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-07392 .NET and Visual Studio Denial of Service Vulnerability CVSS 3.1HIGH 7.5
- TI-2024-17279 Microsoft QUIC Denial of Service Vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2026-70338 · CVE Program
- CVE-2026-70338 · NVD
- FIRST EPSS
- GHSA-mh62-3vqg-v8vm · GitHub Advisory Database · CC BY 4.0
- CVE-2026-70338 · Microsoft Security Update Guide
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences