libvips: A well-crafted PPM image processed via a custom source could lead to possible heap buffer write overflow
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, applications that define unusual custom libvips sources and use them to process untrusted uncompressed PPM images can trigger a max/min error in vips_source_read_to_memory in libvips/iofuncs/source.c. The function uses VIPS_MAX instead of VIPS_MIN when selecting the remaining read size, allowing up to 4032 bytes to be written beyond the allocated heap buffer and causing memory corruption or a process crash. This issue is fixed in version 8.18.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA libvips (libvips) Fixed in 8.18.3
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-70654
References
More libvips vulnerabilities
- TI-2026-02835 libvips extract.c vips_extract_area_build integer overflow CVSS 4.0MEDIUM 4.8
- TI-2026-02834 libvips extract.c vips_extract_band_build out-of-bounds CVSS 4.0MEDIUM 4.8
- TI-2026-02833 libvips unpremultiply.c vips_unpremultiply_build out-of-bounds CVSS 4.0MEDIUM 4.8
- TI-2026-02832 libvips bandrank.c vips_bandrank_build heap-based overflow CVSS 4.0MEDIUM 4.8
- TI-2026-02719 libvips csvload.c vips_foreign_load_csv_build heap-based overflow CVSS 4.0MEDIUM 4.8
- TI-2026-02718 libvips matrixload.c vips_foreign_load_matrix_header null pointer dereference CVSS 4.0MEDIUM 4.8
Sources
- CVE-2026-70654 · CVE Program
- CVE-2026-70654 · NVD
- FIRST EPSS
- CVE-2026-70654 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences