CAI Content Credentials | Improper Input Validation (CWE-20)
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
CAI Content Credentials is affected by an Improper Input Validation vulnerability that could result in an application denial-of-service. An attacker could exploit this vulnerability to crash the application, leading to a denial-of-service condition. Exploitation of this issue does not require user interaction.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | C2PA Tool | up to c2patool-v0.26.70 | c2patool-v0.27.11 | Patch available | CNA |
| Adobe | Content Credentials Rust SDK | up to c2pa-v0.89.0 | c2pa-v0.90.11 | Patch available | CNA |
Remediation
- Fix · CNA C2PA Tool (Adobe) Fixed in c2patool-v0.27.11
- Fix · CNA Content Credentials Rust SDK (Adobe) Fixed in c2pa-v0.90.11
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Adobe C2PA Tool, Content Credentials Rust SDK — helpx.adobe.com/security/products/content-authenticity-sdk/…
6 records Highest priority Priority MEDIUM 3 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2026-50062 CAI Content Credentials | Integer Underflow (Wrap or Wraparound) (CWE-191)Priority MEDIUM 41
- TI-2026-50009 CAI Content Credentials | Uncontrolled Resource Consumption (CWE-400)Priority MEDIUM 41
- TI-2026-53295 CAI Content Credentials | Integer Underflow (Wrap or Wraparound) (CWE-191)Priority LOW 27
Timeline
- 2026-10-02 Threatist record created from CVE-2026-71443
- 2026-10-03 Alias added: GHSA-xcpm-fvj3-727h
More Adobe C2pa vulnerabilities
- TI-2026-73741 Server-side request forgery in Adobe CAI Content Credentials CVSS 3.1HIGH 8.6
- TI-2026-52923 CAI Content Credentials | Uncontrolled Resource Consumption (CWE-400) CVSS 3.1HIGH 7.5
- TI-2026-50062 CAI Content Credentials | Integer Underflow (Wrap or Wraparound) (CWE-191) CVSS 3.1HIGH 7.5
- TI-2026-50009 CAI Content Credentials | Uncontrolled Resource Consumption (CWE-400) CVSS 3.1HIGH 7.5
- TI-2026-35833 CAI Content Credentials | Uncontrolled Resource Consumption (CWE-400) CVSS 3.1HIGH 7.5
- TI-2026-35832 CAI Content Credentials | NULL Pointer Dereference (CWE-476) CVSS 3.1HIGH 7.5
Sources
- CVE-2026-71443 · CVE Program
- CVE-2026-71443 · NVD
- FIRST EPSS
- GHSA-xcpm-fvj3-727h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences