crypto-js: Insufficient Entropy in Cryptographic Secret Generation via Vulnerable CryptoJS Dependency Chain
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
crypto-js is a JavaScript library of crypto standards. Versions of crypto-js prior to 4.0.0 generate randomness in CryptoJS.lib.WordArray.random() using a custom variation of the Multiply-With-Carry pseudorandom number generator, seeded from Math.random(), instead of a cryptographically secure source. This generator was introduced in version 3.1.2-4 and remained present in nearly every 3.x release. Nominal requests for 128 or 256 bits of entropy through this function produce effective search spaces of approximately 2 to the 39th and 2 to the 47th possibilities, small enough to enumerate on commodity hardware. Downstream wallet applications that used CryptoJS.lib.WordArray.random() as the entropy source for BIP39 recovery phrases are affected, and an attacker who enumerates the reduced output space can recover the resulting private keys and control the associated funds. This issue is fixed in version 4.0.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| brix | crypto-js | before 4.0.0 | 4.0.0 | Patch available | CNA |
| — | crypto-js (npm) | before 4.0.0 | 4.0.0 | Patch available | GHSA-rg76-677x-56q9 |
- crypto-js Vendorbrix Affected before 4.0.0 Fixed in 4.0.0 Patch available CNA
- crypto-js (npm) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-rg76-677x-56q9
Remediation
- Fix · CNA crypto-js (brix) Fixed in 4.0.0
- Fix · GHSA-rg76-677x-56q9 crypto-js (npm) Fixed in 4.0.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 6 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Hardened Images
- Red Hat Satellite 6
- Red Hat build of Apache Camel for Spring Boot 4
Timeline
- 2026-10-02 Threatist record created from CVE-2026-71851
- 2026-10-03 Alias added: GHSA-rg76-677x-56q9
References
Sources
- CVE-2026-71851 · CVE Program
- CVE-2026-71851 · NVD
- FIRST EPSS
- GHSA-rg76-677x-56q9 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-71851 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences