Discourse: Stored XSS in staff action logs injects staff UI
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Discourse is an open-source discussion platform. Prior to 2026.1.6, the staff action log model rendered unescaped previous and new value fields that could inject stored cross-site scripting into the staff interface. The issue is fixed in 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00298 22nd percentileScored 2026-11-07
Fix Fixed discourse (discourse): 2026.1.6, 2026.5.2, 2026.6.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| discourse | discourse | before 2026.1.6; 2026.5.0 to before 2026.5.2; 2026.6.0 to before 2026.6.1 | 2026.1.6, 2026.5.2, 2026.6.1 | Patch available | CNA |
- discourse Vendordiscourse Affected before 2026.1.6; 2026.5.0 to before 2026.5.2; 2026.6.0 to before 2026.6.1 Fixed in 2026.1.6, 2026.5.2, 2026.6.1 Patch available CNA
Remediation
- Fix · CNA discourse (discourse) Fixed in 2026.1.6, 2026.5.2, 2026.6.1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-72725
References
Other 4
- https://github.com/discourse/discourse/security/advisories/GHSA-8x29-vv56-wj6v
- https://github.com/discourse/discourse/commit/66601a6e6eeeabfcb06d2f692d68534be12de082
- https://github.com/discourse/discourse/commit/74ae22d85f4e13c7c7f2e3c13fce023feec7e033
- https://github.com/discourse/discourse/commit/fd44510b4303e7f8f0b42bd070a2d42d3cda259f
More discourse vulnerabilities
- TI-2022-22806 Discourse BBCode plugin vulnerable to arbitrary CSS injection CVSS 3.1CRITICAL 9.8
- TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
- TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
- TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
- TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
- TI-2022-18730 Discourse Patreon vulnerable to improper validation of email during Patreon authentication CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences