jupyterlab: PyPI extension blocklist package-name canonicalization bypass
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · High · Low
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.5.0 until 4.5.10 and 4.6.2, in jupyterlab/extensions/manager.py and jupyterlab/extensions/pypi.py, JupyterLab's PyPI extension manager enforces blocked_extensions_uris by comparing requested install names to blocklist entries with custom normalization that is weaker than PyPI package-name canonicalization. An authenticated user can request a PyPI-equivalent spelling such as JupyterLab.Git for a blocklisted package such as jupyterlab-git, and JupyterLab accepts the install request even though pip resolves the variant to the same package. Security impact requires an allowlist or blocklist intended to restrict package installation, the PyPI Extension Manager, and kernels and terminals that are disabled or delegated to remote hosts. The bypass lets an authenticated user install a prohibited extension, defeat integrity restrictions, and affect availability without gaining new read access. This issue is fixed in versions 4.5.10 and 4.6.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterlab | jupyterlab | 4.5.0 to before 4.5.10; 4.6.0 to before 4.6.2 | 4.5.10, 4.6.2 | Patch available | CNA |
| — | jupyterlab (PyPI) | 4.6.0 to before 4.6.2 | 4.6.2 | Patch available | GHSA-89vp-jrxv-24w8 |
| — | jupyterlab (PyPI) | 4.5.0 to before 4.5.10 | 4.5.10 | Patch available | GHSA-89vp-jrxv-24w8 |
- jupyterlab Vendorjupyterlab Affected 4.5.0 to before 4.5.10; 4.6.0 to before 4.6.2 Fixed in 4.5.10, 4.6.2 Patch available CNA
- jupyterlab (PyPI) Vendor— Affected 4.6.0 to before 4.6.2 Fixed in 4.6.2 Patch available GHSA-89vp-jrxv-24w8
- jupyterlab (PyPI) Vendor— Affected 4.5.0 to before 4.5.10 Fixed in 4.5.10 Patch available GHSA-89vp-jrxv-24w8
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* | — | — | jupyterlab |
- cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* Versions — — ·jupyterlab
Remediation
- Fix · CNA jupyterlab (jupyterlab) Fixed in 4.5.10, 4.6.2
- Fix · GHSA-89vp-jrxv-24w8 jupyterlab (PyPI) Fixed in 4.6.2 Advisory →
- Fix · GHSA-89vp-jrxv-24w8 jupyterlab (PyPI) Fixed in 4.5.10 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Migration Toolkit for Applications 8 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-73416
- 2026-10-03 Alias added: GHSA-89vp-jrxv-24w8
- 2026-10-05 EPSS moved to the 50th–90th percentile
References
Other 11
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-89vp-jrxv-24w8
- https://github.com/jupyterlab/jupyterlab/pull/19184
- https://github.com/jupyterlab/jupyterlab/pull/19185
- https://github.com/jupyterlab/jupyterlab/pull/19186
- https://github.com/jupyterlab/jupyterlab/commit/9365f020baec5221deaf11535ed554c06637c999
- https://github.com/jupyterlab/jupyterlab/commit/be9303f5bcd5308eaeae953c5a3c903046682c2c
- https://github.com/jupyterlab/jupyterlab/commit/f1beab4a2027af4719d6edc07d52d6cf5a39a432
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.10
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.2
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.7.0a1
- https://github.com/jupyterlab/jupyterlab
More jupyterlab vulnerabilities
- TI-2026-32161 Jupyter Enterprise Gateway Has Kubernetes Manifest Injection via Jinja2 Template Rendering CVSS 4.0CRITICAL 10.0
- TI-2026-32160 Jupyter Enterprise Gateway: Jinja2 Template Server Side Template Injection results in Remote Code Execution CVSS 4.0CRITICAL 10.0
- TI-2026-32159 Jupyter Enterprise Gateway: ContainerProcessProxy._enforce_prohibited_ids can be Bypassed CVSS 3.1CRITICAL 9.8
- TI-2024-26623 Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action CVSS 3.1CRITICAL 10.0
- TI-2026-78983 Path traversal in nbconvert lets crafted notebooks write files CVSS 4.0HIGH 8.8
- TI-2026-39372 JupyterLab Git: Stored XSS leading to RCE CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-73416 · CVE Program
- CVE-2026-73416 · NVD
- FIRST EPSS
- GHSA-89vp-jrxv-24w8 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-73416 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences