PostGIS < 3.7.0beta2 Out-of-Bounds Read via FlatGeobuf Buffer
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat.
Summary
PostGIS before 3.7.0beta2 contains an out-of-bounds read vulnerability that allows attackers to cause memory disclosure or a server crash by supplying a malformed FlatGeobuf buffer. The FlatGeobuf property metadata decoder verifies that a string length field is present but fails to verify that the subsequent string body is contained within the supplied buffer before materializing it into a SQL-visible value, enabling memory disclosure or denial of service.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA PostGIS (PostGIS) Fixed in 3.7.0beta2
Red Hat 4 advisories
- RHSA-2026:67848 Released 2026-09-16 · Red Hat rating Importantpostgresql:18 security update
- Red Hat Enterprise Linux AppStream (v. 9) pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.aarch64::postgresql:18, pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.ppc64le::postgresql:18, pg_repack-1.5.3-1.module+el9.8.0+23739+1c42644c.s390x::postgresql:18 +47
- RHSA-2026:67491 Released 2026-09-15 · Red Hat rating Importantpostgresql:16 security update
- Red Hat Enterprise Linux AppStream (v. 9) pg_repack-1.5.1-1.module+el9.8.0+24090+8f0ee565.aarch64::postgresql:16, pg_repack-1.5.1-1.module+el9.8.0+24090+8f0ee565.ppc64le::postgresql:16, pg_repack-1.5.1-1.module+el9.8.0+24090+8f0ee565.s390x::postgresql:16 +47
- RHSA-2026:67166 Released 2026-09-14 · Red Hat rating Importantpostgresql18-postgis security update
- Red Hat Enterprise Linux AppStream (v. 10) postgresql18-postgis-3.5.3-1.el10_2.1, postgresql18-postgis-client-3.5.3-1.el10_2.1, postgresql18-postgis-docs-3.5.3-1.el10_2.1 +2
Show 1 more Red Hat advisories
- RHSA-2026:65899 Released 2026-09-09 · Red Hat rating Importantpostgresql16-postgis security update
- Red Hat Enterprise Linux AppStream (v. 10) postgis-3.5.3-4.el10_2.1, postgis-client-3.5.3-4.el10_2.1, postgis-docs-3.5.3-4.el10_2.1 +3
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2026:65899, RHSA-2026:67166 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2026:67491, RHSA-2026:67848 |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-73515
- 2026-10-03 Alias added: GHSA-qv7r-wgc7-6mc6
References
Exploit 1
Other 1
More PostGIS vulnerabilities
- TI-2026-51623 PostGIS address_standardizer Out-of-Bounds Write via standardize_address() CVSS 4.0HIGH 8.7
- TI-2017-13533 PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a… CVSS 3.1HIGH 7.5
- TI-2026-61682 PostGIS address_standardizer through 3.7.0 Out-of-Bounds Read via Unvalidated Rule Weight CVSS 4.0HIGH 7.1
Sources
- CVE-2026-73515 · CVE Program
- CVE-2026-73515 · NVD
- FIRST EPSS
- GHSA-qv7r-wgc7-6mc6 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-73515 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences