phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
phpMyFAQ versions 3.1.0 through 4.1.6 contain an authentication bypass vulnerability in AuthLdap::create(). When LDAP authentication is enabled, after a successful LDAP bind the code calls User::setStatus('active') unconditionally, which overwrites the account_status column of a pre-existing local account from 'blocked' to 'active'. As a result, a user whose local phpMyFAQ account has been administratively blocked can restore their account and log in by authenticating via LDAP. The state transition is not logged, so administrators cannot detect that the block was overridden. Fixed in 4.1.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-76208
- 2026-10-03 Alias added: GHSA-x7f8-q53c-52pw
References
More thorsten Phpmyfaq vulnerabilities
- TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2025-37331 phpMyFAQ duplicate email registration allows multiple accounts with the same email CVSS 3.1CRITICAL 9.8
- TI-2024-36257 phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available CVSS 3.1HIGH 8.6
- TI-2023-03720 Improper Neutralization of Formula Elements in a CSV File in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2023-00749 Command Injection in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2023-00748 Code Injection in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-76208 · CVE Program
- CVE-2026-76208 · NVD
- FIRST EPSS
- GHSA-x7f8-q53c-52pw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences