Renovate before 42.68.5 Remote Code Execution via Gradle Wrapper
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
Renovate versions >=32.124.0 and before 42.68.5 (and Mend renovate-ce/renovate-ee before 13.3.0) contain a command injection vulnerability in Gradle Wrapper artifact handling. When Renovate processes Gradle Wrapper updates, it invokes a wrapper update command via a shell (e.g. /bin/sh -c ... ./gradlew :wrapper --gradle-distribution-url <value>). If an attacker supplies a malicious gradle-wrapper.properties whose distributionUrl contains shell command substitution syntax such as $(...), the shell evaluates it before Gradle parses the URL, resulting in arbitrary command execution in the Renovate runtime. Exploitation requires the attacker to introduce the malicious file into a repository that Renovate scans; the issue occurs even when allowScripts is disabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| renovatebot | renovate | 32.124.0 to before 42.68.5 | 42.68.5 | Patch available | CNA |
| mend | renovate-ce | before 13.3.0 | 13.3.0 | Patch available | CNA |
| mend | renovate-ee-server | before 13.3.0 | 13.3.0 | Patch available | CNA |
| mend | renovate-ee-worker | before 13.3.0 | 13.3.0 | Patch available | CNA |
- renovate Vendorrenovatebot Affected 32.124.0 to before 42.68.5 Fixed in 42.68.5 Patch available CNA
- renovate-ce Vendormend Affected before 13.3.0 Fixed in 13.3.0 Patch available CNA
- renovate-ee-server Vendormend Affected before 13.3.0 Fixed in 13.3.0 Patch available CNA
- renovate-ee-worker Vendormend Affected before 13.3.0 Fixed in 13.3.0 Patch available CNA
Remediation
- Fix · CNA renovate (renovatebot) Fixed in 42.68.5
- Fix · CNA renovate-ce (mend) Fixed in 13.3.0
- Fix · CNA renovate-ee-server (mend) Fixed in 13.3.0
- Fix · CNA renovate-ee-worker (mend) Fixed in 13.3.0
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-76228
- 2026-10-03 Alias added: GHSA-mqp7-cg7m-4hhq
References
More renovatebot vulnerabilities
- TI-2026-53338 Renovate 39.53.0 before 40.33.0 Command Injection via gleam manager CVSS 4.0HIGH 8.4
- TI-2026-53337 Renovate 31.51.0 before 40.33.0 Command Injection via helmv3 CVSS 4.0HIGH 8.4
- TI-2026-53336 Renovate 32.135.0 before 40.33.0 Command Injection via hermit CVSS 4.0HIGH 8.4
- TI-2026-53335 Renovate 35.63.0 before 40.33.0 Command Injection via npm CVSS 4.0HIGH 8.4
- TI-2026-60271 Renovate before 44.11.2 Credential Exfiltration via Link Header CVSS 4.0CRITICAL 9.2
- TI-2026-60266 Renovate before 44.11.2 Credential Exfiltration via Link Header CVSS 4.0CRITICAL 9.2
Sources
- CVE-2026-76228 · CVE Program
- CVE-2026-76228 · NVD
- FIRST EPSS
- GHSA-mqp7-cg7m-4hhq · GitHub Advisory Database · CC BY 4.0
- CVE-2026-76228 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences