FireBox <= 3.1.10 - Authenticated (Author+) Remote Code Execution to Privilege Escalation
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
The FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 3.1.10 via the value function. This is due to a trivially bypassable regex blacklist in Executer::allowedToRun() that fails to block WordPress core functions such as wp_insert_user, update_option, and file_put_contents, combined with no sanitization of PHP condition rule values stored via the firebox_meta REST endpoint. This makes it possible for authenticated attackers, with author-level access and above, to execute code on the server. On sites upgraded from a version prior to 3.1.10, the Migrator::preserveCampaignRoleAccess() function automatically grants the edit_fireboxes and publish_fireboxes capabilities to the Author role, lowering the effective entry point to Author-level access.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fireplugins | FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment | up to 3.1.10 | — | No fix listed | CNA |
- FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment Vendorfireplugins Affected up to 3.1.10 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-76801
- 2026-10-03 Alias added: GHSA-48j6-7xh6-vcfv
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9c1d8ec3-de01-4496-8d8b-b9604f952b1e?source=cve
- https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Framework/Inc/Base/Conditions/Conditions/PHP.php#L36
- https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Framework/Inc/Base/Executer.php#L231
- https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Core/FB/Meta.php#L411
- https://plugins.trac.wordpress.org/browser/firebox/tags/3.1.10/Inc/Core/Migrator.php#L606
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3666018%40firebox&new=3666018%40firebox
More fireplugins vulnerabilities
- TI-2026-10438 FireBox Popups <= 3.1.7 - Unauthenticated Sensitive Information Exposure in 'form_id' Parameter CVSS 3.1MEDIUM 5.3
- TI-2025-41299 WordPress FireBox plugin <= 3.1.0-free - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2026-70249 SQL injection in FireBox popup builder via form display condition CVSS 3.1MEDIUM 5.3
Sources
- CVE-2026-76801 · CVE Program
- CVE-2026-76801 · NVD
- FIRST EPSS
- GHSA-48j6-7xh6-vcfv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences