Content Mask 1.8.0 - 1.8.5.4 - Contributor Publish Capability Bypass via create_new_content_mask
Priority LOW 13CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-269.
Summary
The Content Mask WordPress plugin before 1.8.5.5 does not check the capability required to publish the post type being created, allowing users with a role as low as Contributor to publish posts and pages on the site without holding the publish capability.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00281 20th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Content Mask (Unknown): 1.8.5.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Content Mask | 1.8.0 to before 1.8.5.5 | 1.8.5.5 | Patch available | CNA |
- Content Mask VendorUnknown Affected 1.8.0 to before 1.8.5.5 Fixed in 1.8.5.5 Patch available CNA
Remediation
- Fix · CNA Content Mask (Unknown) Fixed in 1.8.5.5
Timeline
- 2026-10-02 Threatist record created from CVE-2026-77003
- 2026-10-03 Alias added: GHSA-mfj2-2xr8-6w24
References
Sources
- CVE-2026-77003 · CVE Program
- CVE-2026-77003 · NVD
- FIRST EPSS
- GHSA-mfj2-2xr8-6w24 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences