Restrict User Access 2.6 - 2.8 - Unauthenticated Content Protection Bypass via REST API Route Normalization
Priority LOW 30CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
The Restrict User Access WordPress plugin before 2.8.1 does not normalise the REST API route before checking it against the routes its content protection covers, allowing unauthenticated users to bypass that protection and read restricted content and enumerate users.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0035 28th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Restrict User Access (Unknown): 2.8.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Restrict User Access | 2.6 to before 2.8.1 | 2.8.1 | Patch available | CNA |
- Restrict User Access VendorUnknown Affected 2.6 to before 2.8.1 Fixed in 2.8.1 Patch available CNA
Remediation
- Fix · CNA Restrict User Access (Unknown) Fixed in 2.8.1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-78153
- 2026-10-03 Alias added: GHSA-2hp9-5v75-v9jj
References
Sources
- CVE-2026-78153 · CVE Program
- CVE-2026-78153 · NVD
- FIRST EPSS
- GHSA-2hp9-5v75-v9jj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences