Ajenti: Privilege escalation to root via unauthenticated/unauthorized plugin install task
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
Ajenti is a Linux & BSD modular server admin panel. Prior to version 2.2.16, any authenticated user can call /api/core/tasks/start to enqueue InstallPlugin, UnInstallPlugin, or UpgradeAll from plugins/plugins/tasks.py without plugin-management authorization. InstallPlugin and UnInstallPlugin construct a pip package specification from unvalidated name and version fields, and the task worker invokes pip while running as root. A low-privileged user can therefore select or manipulate a package installed with root privileges and can install, remove, or upgrade plugins without administrative permission, resulting in root code execution and full host compromise. This issue is fixed in version 2.2.16.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA ajenti (ajenti) Fixed in 2.2.16
Timeline
- 2026-10-02 Threatist record created from CVE-2026-79920
- 2026-11-03 EPSS moved to the 50th–90th percentile
References
More ajenti vulnerabilities
- TI-2019-15206 ajenti API privileges management CVSS 3.1HIGH 8.8
- TI-2026-28991 Password bypass when 2FA is activated CVSS 4.0CRITICAL 9.3
- TI-2026-22317 Ajenti has a potential Remote Code Execution CVSS 4.0HIGH 8.1
- TI-2018-15737 Ajenti version version 2 contains a Cross ite Request Forgery (CSRF) vulnerability in the… CVSS 3.0HIGH 8.8
- TI-2018-15779 Ajenti version 2 contains an Information Disclosure vulnerability in Line 176 of the code… CVSS 3.0HIGH 7.5
- TI-2018-15736 Ajenti version version 2 contains a Input Validation vulnerability in ID string on… CVSS 3.0HIGH 7.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences