CMB2 < 2.13.0 - Subscriber+ Arbitrary Option Corruption via oEmbed Handler
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-862.
Summary
The CMB2 WordPress plugin before 2.13.0 does not perform any capability check on one of its AJAX actions, allowing users with a role as low as Subscriber to create arbitrary WordPress options and corrupt existing ones, which can break core site settings and take the site offline. Exploitation requires the site's or another CMB2 WordPress plugin before 2.13.0 to have declared an oEmbed field, as the CMB2 WordPress plugin before 2.13.0 registers none of its own. The stored value is never attacker-controlled, so the issue does not lead to privilege escalation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | CMB2 | before 2.13.0 | 2.13.0 | Patch available | CNA |
- CMB2 VendorUnknown Affected before 2.13.0 Fixed in 2.13.0 Patch available CNA
Remediation
- Fix · CNA CMB2 (Unknown) Fixed in 2.13.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-80338
- 2026-10-03 Alias added: GHSA-vf5h-xv4f-wc7g
References
Sources
- CVE-2026-80338 · CVE Program
- CVE-2026-80338 · NVD
- FIRST EPSS
- GHSA-vf5h-xv4f-wc7g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences