openssl_encrypt before 1.4.9 KDF Downgrade via CWD-relative Configuration
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-426.
Summary
openssl_encrypt (pip package openssl-encrypt) versions <= 1.4.8 contain a CWD-relative configuration file resolution flaw in crypt_settings.py, where CONFIG_FILE (originally the absolute per-user path ~/.crypt_settings.json) is reassigned at line 84 to the bare relative name 'crypt_settings.json'. As a result, the legacy Tk GUI's SettingsTab reads and writes KDF settings from crypt_settings.json in the process launch (current working) directory instead of the user's home directory. An attacker who plants a malicious crypt_settings.json (e.g. sha256:1 with all memory-hard KDFs disabled) can silently downgrade encryption performed in that GUI session to roughly one hash round, bypassing the weak-KDF preflight and enabling offline brute-force attacks against the resulting ciphertext. Fixed in 1.4.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA openssl_encrypt (jahlives) Fixed in 1.4.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
jahlives openssl_encrypt 1.4.9
36 records Highest priority Priority MEDIUM 24 MEDIUM, 12 LOW
Other records, highest priority first
- TI-2026-56361 openssl_encrypt before 1.4.9 ANSI Escape Injection via Identity EmailPriority MEDIUM 49
- TI-2026-56355 openssl_encrypt before 1.4.9 Arbitrary Code Execution via unsigned pluginPriority MEDIUM 48
- TI-2026-56354 openssl_encrypt before 1.4.9 GPG Signature Verification BypassPriority MEDIUM 48
Timeline
- 2026-10-02 Threatist record created from CVE-2026-81697
- 2026-10-03 Alias added: GHSA-7wp9-wpj9-m7pm
References
More jahlives vulnerabilities
- TI-2026-52616 openssl_encrypt before 1.4.0 Sandbox Escape via Type Hierarchy CVSS 4.0CRITICAL 9.3
- TI-2026-52615 openssl_encrypt before 1.4.0 Sandbox Escape via Dunder Attribute Traversal CVSS 4.0CRITICAL 9.3
- TI-2026-52602 openssl_encrypt before 1.4.0 Sandbox Bypass via pathlib and io CVSS 4.0HIGH 8.7
- TI-2026-56361 openssl_encrypt before 1.4.9 ANSI Escape Injection via Identity Email CVSS 4.0CRITICAL 9.3
- TI-2026-52617 openssl_encrypt before 1.4.0 Weak Shared Secret via PQC Simulation Mode CVSS 4.0CRITICAL 9.3
- TI-2026-52614 openssl_encrypt before 1.4.0 Plugin Sandbox Bypass via Process Isolation CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-81697 · CVE Program
- CVE-2026-81697 · NVD
- FIRST EPSS
- GHSA-7wp9-wpj9-m7pm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences