Remote CPU denial of service through cached SVCB/HTTPS AliasMode trees
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
If a BIND resolver has cached a tree of SVCB/HTTPS AliasMode records, and is then queried for the root of that tree, the resolver will spend disproportionate CPU time constructing the response. This issue affects BIND 9 versions 9.18.0 through 9.18.50, 9.20.0 through 9.20.27, 9.21.0 through 9.21.25, 9.18.11-S1 through 9.18.50-S1, and 9.20.9-S1 through 9.20.27-S1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ISC | BIND 9 | 9.18.0 – 9.18.50; 9.20.0 – 9.20.27; 9.21.0 – 9.21.25; 9.18.11-S1 – 9.18.50-S1; 9.20.9-S1 – 9.20.27-S1 | — | No fix listed | CNA |
- BIND 9 VendorISC Affected 9.18.0 – 9.18.50; 9.20.0 – 9.20.27; 9.21.0 – 9.21.25; 9.18.11-S1 – 9.18.50-S1; 9.20.9-S1 – 9.20.27-S1 Fixed in — No fix listed CNA
Remediation
Red Hat 5 advisories
- RHSA-2026:94278 Released 2026-11-03 · Red Hat rating Importantbind9.18 security, bug fix, and enhancement update
- Red Hat CodeReady Linux Builder EUS (v.9.6) bind9.18-libs-32:9.18.29-4.el9_6.5
- Red Hat Enterprise Linux AppStream EUS (v.9.6) bind9.18-32:9.18.29-4.el9_6.5, bind9.18-dnssec-utils-32:9.18.29-4.el9_6.5, bind9.18-libs-32:9.18.29-4.el9_6.5
- RHSA-2026:94115 Released 2026-11-03 · Red Hat rating Importantbind security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream EUS (v. 10.0) bind-32:9.18.33-4.el10_0.6, bind-dnssec-utils-32:9.18.33-4.el10_0.6, bind-libs-32:9.18.33-4.el10_0.6
- RHSA-2026:75578 Released 2026-10-05 · Red Hat rating Importantbind9.18 security update
- Red Hat Enterprise Linux AppStream (v. 9) bind9.18-32:9.18.29-14.el9_8.10, bind9.18-chroot-32:9.18.29-14.el9_8.10, bind9.18-dnssec-utils-32:9.18.29-14.el9_8.10 +2
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) bind9.18-devel-32:9.18.29-14.el9_8.10, bind9.18-doc-32:9.18.29-14.el9_8.10, bind9.18-libs-32:9.18.29-14.el9_8.10
Show 2 more Red Hat advisories
- RHSA-2026:75577 Released 2026-10-05 · Red Hat rating Importantbind security update
- Red Hat Enterprise Linux AppStream (v. 10) bind-32:9.18.33-15.el10_2.12, bind-chroot-32:9.18.33-15.el10_2.12, bind-dnssec-utils-32:9.18.33-15.el10_2.12 +3
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) bind-devel-32:9.18.33-15.el10_2.12, bind-doc-32:9.18.33-15.el10_2.12
- RHSA-2026:68279 Released 2026-09-16 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images bind-32:9.20.29-0.1.hum1@aarch64, bind-32:9.20.29-0.1.hum1@src, bind-32:9.20.29-0.1.hum1@x86_64 +12
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat CodeReady Linux Builder EUS (v.9.6) | Fixed | RHSA-2026:94278 |
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2026:75577 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2026:75578 |
| Red Hat Enterprise Linux AppStream EUS (v. 10.0) | Fixed | RHSA-2026:94115 |
| Red Hat Enterprise Linux AppStream EUS (v.9.6) | Fixed | RHSA-2026:94278 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) | Fixed | RHSA-2026:75577 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) | Fixed | RHSA-2026:75578 |
| Red Hat Hardened Images | Fixed | RHSA-2026:68279 |
Not affected: 10 products
- Red Hat CodeReady Linux Builder EUS (v.9.6)
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Enterprise Linux AppStream EUS (v. 10.0)
- Red Hat Enterprise Linux AppStream EUS (v.9.6)
- Red Hat Enterprise Linux CodeReady Linux Builder EUS (v. 10.0)
- Red Hat OpenShift Container Platform 4
- Red Hat OpenShift Container Platform 5
Timeline
- 2026-10-02 Threatist record created from CVE-2026-81736
- 2026-10-03 Alias added: GHSA-hjmx-qf9h-v7mw
- 2026-10-05 EPSS moved to the below the 50th percentile
- 2026-10-05 Fix available: RHSA-2026:75577 · Red Hat
- 2026-10-05 Fix available: Red Hat Enterprise Linux AppStream (v. 10), Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) · Red Hat
- 2026-10-06 Fix available: RHSA-2026:75578 · Red Hat
- 2026-10-06 Fix available: Red Hat Enterprise Linux AppStream (v. 9), Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) · Red Hat
- 2026-10-30 Affected versions changed · Red Hat
- 2026-11-03 Fix available: RHSA-2026:94115 · Red Hat
- 2026-11-03 Fix available: RHSA-2026:94278 · Red Hat
- 2026-11-03 Fix available: Red Hat CodeReady Linux Builder EUS (v.9.6), Red Hat Enterprise Linux AppStream EUS (v. 10.0), Red Hat Enterprise Linux AppStream EUS (v.9.6) · Red Hat
References
More ISC vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-1999-00042 Command execution via shell metachars in INN daemon (innd) 1.5 using "newgroup" and… CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2025-27240 Cache poisoning attacks with unsolicited RRs CVSS 3.1HIGH 8.6
Sources
- CVE-2026-81736 · CVE Program
- CVE-2026-81736 · NVD
- FIRST EPSS
- GHSA-hjmx-qf9h-v7mw · GitHub Advisory Database · CC BY 4.0
- CVE-2026-81736 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences