DeepSeek Harness < 0.1.2-alpha.1 Authentication Bypass via Host Header Spoofing
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
DeepSeek Harness before 0.1.2-alpha.1 contains an authentication bypass vulnerability that grants unauthenticated access to its local HTTP agent-control API by accepting a client-supplied loopback Host header in place of validating the actual TCP connection origin. On the default configuration, a confined tool-executed process can reach the loopback API without any port exposure and use it to escape its own OS sandbox, escalate to unconfined execution, and disable the approval prompt. When the port is externally reachable via tunnel, SSH forward, or reverse proxy, a remote attacker can exploit the same flaw to create sessions, execute arbitrary commands, and exfiltrate stored conversation transcripts without credentials.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| DeepSeek | DeepSeek Harness | before 0.1.2-alpha.1 | 0.1.2-alpha.1 | Patch available | CNA |
| — | @deepseek-ai/dsh-client-connection (npm) | before 0.1.2-alpha.1 | 0.1.2-alpha.1 | Patch available | GHSA-8m2g-8cgm-3vcp |
- DeepSeek Harness VendorDeepSeek Affected before 0.1.2-alpha.1 Fixed in 0.1.2-alpha.1 Patch available CNA
- @deepseek-ai/dsh-client-connection (npm) Vendor— Affected before 0.1.2-alpha.1 Fixed in 0.1.2-alpha.1 Patch available GHSA-8m2g-8cgm-3vcp
Remediation
- Fix · CNA DeepSeek Harness (DeepSeek) Fixed in 0.1.2-alpha.1
- Fix · GHSA-8m2g-8cgm-3vcp @deepseek-ai/dsh-client-connection (npm) Fixed in 0.1.2-alpha.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-82533
- 2026-10-03 Alias added: GHSA-8m2g-8cgm-3vcp
- 2026-10-07 Fix available: npm/@deepseek-ai/[email protected] · GHSA-8m2g-8cgm-3vcp
- 2026-10-07 CVSS score added · GHSA-8m2g-8cgm-3vcp
- 2026-10-07 Weakness changed · GHSA-8m2g-8cgm-3vcp
- 2026-10-07 5 new references · GHSA-8m2g-8cgm-3vcp
References
More DeepSeek vulnerabilities
- TI-2025-19267 DeepSeek R1 through V3.1 allows XSS, as demonstrated by JavaScript execution in the… CVSS 3.1HIGH 8.8
- TI-2026-80466 Access control flaw in DeepSeek sandbox createContext CVSS 4.0MEDIUM 5.3
- TI-2026-65141 DeepSeek deepseek-harness Bundle Patch profile.ts loadProfile path traversal CVSS 4.0LOW 2.3
- TI-2026-80467 Improper authorization in DeepSeek browser authentication CVSS 4.0MEDIUM 6.9
- TI-2025-39472 DeepSeek V3.2 has a Cross Site Scripting (XSS) vulnerability, which allows JavaScript… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2026-82533 · CVE Program
- CVE-2026-82533 · NVD
- FIRST EPSS
- GHSA-8m2g-8cgm-3vcp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences