Cross-site scripting in Contec Co., Ltd. Remote I/O Coupler Unit CPSN-MCB271-*
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting vulnerability exists in CONPROSYS nano Series. If this vulnerability is exploited, an arbitrary script may be executed on a logged-in user's web browser.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Contec Co., Ltd. | Remote I/O Coupler Unit (Server Type) CPSN-MCB271-* | before 1.82 | 1.82 | Patch available | CNA |
| Contec Co., Ltd. | Remote I/O Coupler Unit (EtherNet/IP Adapter) CPSN-EOB471EI-[]1 | before 1.02 | 1.02 | Patch available | CNA |
| Contec Co., Ltd. | Programmable Remote I/O Coupler Unit (Software PLC Type) CPSN-PCB271-S1-041 | before 1.61 | 1.61 | Patch available | CNA |
- Remote I/O Coupler Unit (Server Type) CPSN-MCB271-* VendorContec Co., Ltd. Affected before 1.82 Fixed in 1.82 Patch available CNA
- Remote I/O Coupler Unit (EtherNet/IP Adapter) CPSN-EOB471EI-[]1 VendorContec Co., Ltd. Affected before 1.02 Fixed in 1.02 Patch available CNA
- Programmable Remote I/O Coupler Unit (Software PLC Type) CPSN-PCB271-S1-041 VendorContec Co., Ltd. Affected before 1.61 Fixed in 1.61 Patch available CNA
Remediation
- Fix · CNA Remote I/O Coupler Unit (Server Type) CPSN-MCB271-* (Contec Co., Ltd.) Fixed in 1.82
- Fix · CNA Remote I/O Coupler Unit (EtherNet/IP Adapter) CPSN-EOB471EI-[]1 (Contec Co., Ltd.) Fixed in 1.02
- Fix · CNA Programmable Remote I/O Coupler Unit (Software PLC Type) CPSN-PCB271-S1-041 (Contec Co., Ltd.) Fixed in 1.61
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Contec Remote I/O Coupler Unit (Server Type) CPSN-MCB271-* 1.82
7 records Highest priority Priority LOW 7 LOW
Other records, highest priority first
- TI-2026-57102 Missing authentication in Contec Co., Ltd. Remote I/O Coupler Unit CPSN-MCB271-*Priority LOW 36
- TI-2026-57104 Insufficiently protected credentials in Contec Co., Ltd. Remote I/O Coupler Unit…Priority LOW 35
- TI-2026-57103 Stack-based buffer overflow in Contec Co., Ltd. Remote I/O Coupler Unit CPSN-MCB271-*Priority LOW 25
- Release ·
Contec Programmable Remote I/O Coupler Unit (Software PLC Type) CPSN-PCB271-S1-041, Remote I/O Coupler Unit (EtherNet/IP Adapter) CPSN-EOB471EI-[]1 1.02, 1.61
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2026-57100 Out-of-bounds write in Contec Co., Ltd. Remote I/O Coupler Unit CPSN-MCB271-*Priority LOW 24
- TI-2026-57082 Cross-site request forgery in Contec Co., Ltd. FXA5000Priority LOW 23
- TI-2026-57101 Plaintext storage of a password issue exists in CONPROSYS nano Series .Priority LOW 18
Timeline
- 2026-10-02 Threatist record created from CVE-2026-82781
- 2026-10-03 Alias added: GHSA-jww6-h856-xhj9
References
More Contec Co., Ltd. vulnerabilities
- TI-2022-11821 SolarView Compact ver.6.00 was discovered to contain a command injection vulnerability via conf_mail.php. KEVCVSS 3.1CRITICAL 9.8
- TI-2023-09196 There is a command injection vulnerability in SolarView Compact through 6.00, attackers… CVSS 3.1CRITICAL 9.8
- TI-2022-21852 OS command injection in Contec Co., Ltd. CONPROSYS HMI System CVSS 3.1CRITICAL 9.8
- TI-2023-14072 SolarView Compact <= 6.0 is vulnerable to Insecure Permissions. CVSS 3.1CRITICAL 9.8
- TI-2022-21787 SolarView Compact 4.0 and 5.0 is vulnerable to Unrestricted File Upload via a crafted php file. CVSS 3.1CRITICAL 9.8
- TI-2022-19462 SolarView Compact 6.00 was discovered to contain a command injection vulnerability via network_test.php CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-82781 · CVE Program
- CVE-2026-82781 · NVD
- FIRST EPSS
- GHSA-jww6-h856-xhj9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences