An improper neutralization of directives in dynamically evaluated code ('Eval Injection')…
Priority MEDIUM 40CWE-95Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-95.
Summary
An improper neutralization of directives in dynamically evaluated code ('Eval Injection') issue exists in CONPROSYS HMI System(CHS). If exploited, arbitrary code may be executed by an attacker who can log in to the product.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00549 46th percentileScored 2026-11-07
Fix Fixed CONPROSYS HMI System(CHS) (Contec): 3.8.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Contec Co., Ltd. | CONPROSYS HMI System(CHS) | before 3.8.0 | 3.8.0 | Patch available | CNA |
- CONPROSYS HMI System(CHS) VendorContec Co., Ltd. Affected before 3.8.0 Fixed in 3.8.0 Patch available CNA
Remediation
- Fix · CNA CONPROSYS HMI System(CHS) (Contec) Fixed in 3.8.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-82789
- 2026-10-03 Alias added: GHSA-6c68-h54j-7c3w
References
More Contec Co., Ltd. vulnerabilities
- TI-2022-11821 SolarView Compact ver.6.00 was discovered to contain a command injection vulnerability via conf_mail.php. KEVCVSS 3.1CRITICAL 9.8
- TI-2023-09196 There is a command injection vulnerability in SolarView Compact through 6.00, attackers… CVSS 3.1CRITICAL 9.8
- TI-2022-21852 OS command injection in Contec Co., Ltd. CONPROSYS HMI System CVSS 3.1CRITICAL 9.8
- TI-2023-14072 SolarView Compact <= 6.0 is vulnerable to Insecure Permissions. CVSS 3.1CRITICAL 9.8
- TI-2022-21787 SolarView Compact 4.0 and 5.0 is vulnerable to Unrestricted File Upload via a crafted php file. CVSS 3.1CRITICAL 9.8
- TI-2022-19462 SolarView Compact 6.00 was discovered to contain a command injection vulnerability via network_test.php CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-82789 · CVE Program
- CVE-2026-82789 · NVD
- FIRST EPSS
- GHSA-6c68-h54j-7c3w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences