@pdfme/schemas before 5.5.9 Cross-Site Scripting via Select
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
@pdfme/schemas before 5.5.9 contains a cross-site scripting vulnerability in the Select schema plugin that fails to sanitize option values before interpolating them into HTML via innerHTML. Attackers can supply malicious templates with crafted option values containing HTML and JavaScript to execute arbitrary code in users' browsers.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA schemas (pdfme) Fixed in 5.5.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
pdfme schemas 5.5.9
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2026-57172 @pdfme/schemas before 5.5.9 Cross-Site Scripting via SVGPriority MEDIUM 57
Timeline
- 2026-10-02 Threatist record created from CVE-2026-82867
- 2026-10-03 Alias added: GHSA-q78q-xrxw-xgx6
References
More pdfme vulnerabilities
- TI-2026-79748 Server-side request forgery in @pdfme/common denylist bypass CVSS 4.0HIGH 8.9
- TI-2026-57170 @pdfme/common before 5.5.10 SSRF via Unvalidated URL Fetch CVSS 4.0HIGH 8.9
- TI-2025-33553 pdfme has Sandbox Escape and Prototype Pollution vulnerabilities in pdfme expression evaluation CVSS 3.1MEDIUM 6.1
- TI-2026-57172 @pdfme/schemas before 5.5.9 Cross-Site Scripting via SVG CVSS 4.0MEDIUM 5.3
- TI-2026-57169 pdfme schemas before 5.5.10 Cross-Site Scripting via i18n Label CVSS 4.0LOW 2.1
- TI-2026-57168 pdfme pdf-lib before 5.5.10 Denial of Service via Decompression Bomb CVSS 4.0HIGH 7.1
Sources
- CVE-2026-82867 · CVE Program
- CVE-2026-82867 · NVD
- FIRST EPSS
- GHSA-q78q-xrxw-xgx6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences